AssocArrayPathParameters Class

This .NET class wraps the OdDbAssocArrayPathParameters class. It provides an interface for managing array path parameters.
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.RuntimeRXObject
        Teigha.DatabaseServicesAssocArrayParameters
          Teigha.DatabaseServicesAssocArrayCommonParameters
            Teigha.DatabaseServicesAssocArrayPathParameters

Namespace: Teigha.DatabaseServices
Assembly: TD_MgdDbConstraints (in TD_MgdDbConstraints.dll) Version: 0.0.0.0
Syntax
public class AssocArrayPathParameters : AssocArrayCommonParameters

The AssocArrayPathParameters type exposes the following members.

Constructors
  Name Description
Public method AssocArrayPathParameters Default constructor for the AssocArrayPathParameters class. Creates an object that wraps a corresponding default OdDbAssocArrayPathParameters C++ object.
Public method AssocArrayPathParameters(Double, Double, Double, Int32, Int32, Int32, Double) Constructor for the AssocArrayPathParameters class. Creates an object with the specified spacing, count and elevation parameters.
Top
Properties
  Name Description
Public property AlignItems  
Public property EndOffset  
Public property ItemCount  
Public property ItemSpacing  
Public property Method  
Public property Path  
Public property PathDirection  
Public property StartOffset  
Top
Methods
  Name Description
Public method GetEndOffset Retrieves the end offset of the path array. The end offset is only available when using the MethodType.Divide arrangement type. If there is no expression for a particular parameter, the expression and the evaluatorId strings are empty after the method executes.
Public method GetItemCount Retrieves the item count of the path array. If there is no expression for a particular parameter, the expression and the evaluatorId strings are empty after the method executes.
Public method GetItemSpacing Retrieves the item spacing of the path array. If there is no expression for a particular parameter, the expression and the evaluatorId strings are empty after the method executes.
Public method GetStartOffset Retrieves the start spacing of the path array. If there is no expression for a particular parameter, the expression and the evaluatorId strings are empty after the method executes.
Public method SetEndOffset Sets the end offset of the path array. The end offset is only available when using the MethodType.Divide arrangement type. If there is no expression for a particular parameter, the expression and the evaluatorId strings must be empty.
Public method SetItemCount Sets the item count of the path array. If there is no expression for a particular parameter, the expression and the evaluatorId strings must be empty.
Public method SetItemSpacing Sets the item spacing of the path array. If there is no expression for a particular parameter, the expression and the evaluatorId strings must be empty.
Public method SetStartOffset Sets the start offset of the path array. If there is no expression for a particular parameter, the expression and the evaluatorId strings must be empty.
Top
See Also

©  Bricsys NV. All rights reserved.