LinkedTableData Class

Inheritance Hierarchy
Namespace:  Teigha.DatabaseServices
Assembly:  TD_Mgd (in TD_Mgd.dll) Version: 21.4.0.0
Syntax
public class LinkedTableData : LinkedData

The LinkedTableData type exposes the following members.

Constructors
  Name Description
Public method LinkedTableData
Initializes a new instance of the LinkedTableData class
Protected method LinkedTableData(IntPtr, Boolean)
Initializes a new instance of the LinkedTableData class
Top
Properties
  Name Description
Public property NumberOfColumns
Public property NumberOfRows
Top
Methods
  Name Description
Public method AppendColumn
Public method AppendRow
Protected methodStatic member Create
Public method DataType
Public method DeleteColumn
Public method DeleteContent
Public method DeleteRow
Public method GetBlockAttributeValue
Public method GetBlockTableRecordId
Public method GetCellState
Public method GetColumnName
Public method GetContentTypes
Public method GetCustomData
Public method GetDataFormat
Public method GetDataLink
Public method GetDataLink(CellRange)
Public method GetDataLink(Int32, Int32)
Public method GetEnumerator
Public method GetEnumerator(TableEnumeratorOption)
Public method GetFieldId
Public method GetToolTip
Public method GetValue(Int32, Int32)
Public method GetValue(Int32, Int32, Int32, FormatOption)
Public method InsertColumn
Public method InsertRow
Public method IsContentEditable
Public method IsLinked
Public method SetBlockAttributeValue
Public method SetBlockTableRecordId
Public method SetCellState
Public method SetColumnName
Public method SetCustomData
Public method SetDataFormat
Public method SetDataLink(CellRange, ObjectId, Boolean)
Public method SetDataLink(Int32, Int32, ObjectId, Boolean)
Public method SetDataType
Public method SetFieldId
Public method SetSize
Public method SetToolTip
Public method SetValue(Int32, Int32, Object)
Public method SetValue(Int32, Int32, Int32, Object, ParseOption)
Public method UnitType
Public method UpdateDataLink(UpdateDirection, UpdateOption)
Public method UpdateDataLink(Int32, Int32, UpdateDirection, UpdateOption)
Top
Events
  Name Description
Top
See Also

©  Bricsys NV. All rights reserved.