Overview
LISP (LISt Processing)
DCL (Dialog Control Language)
Structure of a DCL File
Typical usage sequence
Tiles
Cluster tiles
cluster
dialog
Child tiles
button
edit_box
image
image_button
list_box
popup_list
radio_button
slider
spacer
text
text_part
toggle
Other
default_dcl_settings
Functions
action_tile
add_list
client_data_tile
dimx_tile
dimy_tile
done_dialog
end_image
end_list
fill_image
get_attr
get_tile
init_dialog
load_dialog
mode_tile
new_dialog
set_tile
slide_image
start_dialog
start_image
start_list
term_dialog
unload_dialog
vector_image
Attributes
audit_level
bcad_font
bcad_height
bcad_label
bcad_skip_next_child
bcad_width
bcad_win_wrap
height
is_enabled
key
label
list
mnemonic
tab_truncate
tabs
width
DIESEL (Direct Interpretively Evaluated String Expression Language)
Functions
+ (addition)
- (subtraction)
* (multiplication)
/ (division)
= (equal to)
< (less than)
> (greater than)
!= (not equal to)
<= (less than or equal to)
>= (greater than or equal to)
and
edtime
eq
eval
fix
getenv
getvar
if
index
nth
or
strfill
strlen
substr
time
upper
xor
COM (Component Object Model)
The BricsCAD Automation Object Model
User Guide
Drawing Lines and Arcs
Drawing Lines
Drawing Polylines
Drawing Arcs
Drawing Circles
Creating Other Objects
Creating Points
Creating Splines
Adding Hatching
Adding Text to Drawings
Creating Single-Line Text
Creating Paragraph Text
Working with Text Styles
Working with Views
Using Named Views
Using Viewports
Reference Guide
Objects
AcCmColor Object
Application object
ApplicationPreferences object
Arc object
Attribute object
AttributeReference object
Block object
BlockReference object
Blocks collection object
Circle object
Dictionary object
Dictionaries collection object
Dim3PointAngular object
DimAligned object
DimAngular object
DimDiametric object
Dimension object
DimensionStyle object
DimensionStyles collection object
DimOrdinate object
DimRadial object
DimRotated object
Document object
DocumentPreferences object
Documents collection object
Ellipse object
Entity object
ExternalReference object
Face3D object
Group object
Groups collection object
Hyperlink object
Hyperlinks collection object
Hatch object
Image object
InfiniteLine object
Layer object
Layers collection object
Layout object
Layouts collection object
Leader object
Line object
Linetype object
Linetypes collection object
LWPolyline object
MenuBar object
MenuGroup object
MenuGroups object
ModelSpace collection object
MText object
PaperSpace collection object
PlotConfiguration object
PlotConfigurations collection object
Plot object
Point object
PolyfaceMesh object
PolygonMesh object
Polyline object
Polyline3D object
PopupMenu object
PopupMenus object
PopupMenuItem object
Preferences object
PViewport object
Ray object
Region object
RegisteredApplication object
RegisteredApplications collection object
SelectionSet object
SelectionSets collection object
Shape object
Solid object
Solid3D object
SolidCreator 0bject
Spline object
Text object
TextStyle object
TextStyles collection object
Tolerance object
Toolbar object
Toolbars object
Trace object
UserCoordSystem object
UserCoordSystems collection object
Utility object
View object
Views collection object
Viewport object
Viewports collection object
Window object
Windows collection object
Workspace object
XRecord object
Properties
ActiveDocument property
AltFontFile property
Application property
Area property
AutoSaveInterval property
Caption property
Center property
CenterPlot property
Circumference property
Closed property
Color property
Constant property
ContourLinesPerSurface property
Coordinates property
Count property
CursorSize property
Diameter property
DisplayScrollBars property
DisplaySilhouette property
DockedVisibleLines property
Document property
Documents property
EndAngle property
EndPoint property
FieldLength property
FullName property
GraphicsWinBackgrndColor property
Handle property
HasAttributes property
HasExtensionDictionary property
Height property
HistoryLines property
HorizontalAlignment property
ImageFile property
ImageHeight property
ImageVisibility property
ImageWidth property
Index property
InsertionPoint property
Invisible property
IsXRef property
Item property
Layer property
Length property
Linetype property
LinetypeScale property
LineWeight property
LocaleID property
LogFilePath property
LogFileOn property
MaxActiveViewports property
MaxAutoCADWindow property
Mode property
Name property
Normal property
ObjectName property
ObliqueAngle property
Origin property
PaperOrientation property
PaperSpace property
Path property
PlotManager property
PlotStyleName property
Preferences property
Preset property
PromptString property
Radius property
ReadOnly property
RenderSmoothness property
Rotation property
Saved property
ScaleFactor property
SegmentPerPolyline property
SolidFill property
StartAngle property
StartPoint property
StyleName property
TagString property
TextAlignmentPoint property
TextFrameDisplay property
TextGenerationFlag property
TextString property
Thickness property
Units property
URL property
VBE property
Verify property
Version property
VerticalAlignment property
View property
VisibilityEdgeX property
Visible property
Width property
WindowTop property
XRefLayerVisibility property
XScaleFactor property
YScaleFactor property
ZScaleFactor property
Methods
Activate method
Add method
Add3dFace method
Add3DMesh method
Add3dPoly method
AddArc method
AddBox method
AddAttributeDef method
AddCircle method
AddCone method
AddCylinder method
AddDimAligned method
AddDim3PointAngular method
AddDimAngular method
AddDimDiametric method
AddDimOrdinate method
AddDimRadial method
AddDimRotated method
AddEllipse method
AddFitPoint method
AddHatch method
AddImage method
AddXLine method
AddItems method
AddLeader method
AddLightWeightPolyline method
AddLine method
AddMtext method
AddPointEntity method
AddPolyfaceMesh method
AddPolyline method
AddPViewport method
AddRay method
AddSolid method
AddSphere method
AddSpline method
AddText method
AddTolerance method
AddTorus method
AddTrace method
AddVertex method
AddWedge method
AngleFromXAxis method
AngleToReal method
AngleToString method
AppendVertex method
ArrayPolar method
ArrayRectangular method
AttachExternalReference method
Bind method
Clear method
Close method
Copy method
Delete method
DefineFunction method
DeleteFitPoint method
Detach method
Display method
Erase method
Explode method
Export method
GetAngle method
GetAttributes method
GetBoundingBox method
GetBulge method
GetControlPoint method
GetCorner method
GetExtensionDictionary method
GetGridSpacing method
GetInterfaceObject method
GetInvisibleEdge method
GetSnapSpacing method
GetUCSMatrix method
GetVariable method
GetWidth method
GetXData method
GetXData and SetXData Method Example
HandleToObject method
Highlight method
Import method
InsertBlock method
IntersectWith method
Item method
Mirror method
Mirror3D method
Move method
Offset method
Open method
DisplayPlotPreview method
Parent method
PlotToDevice method
PlotToFile method
PurgeAll method
Quit method
Regen method
Reload method
RemoveItems method
Rotate method
Rotate3D method
RunCommand method
RunScript method
Save method
SaveAs method
ScaleEntity method
Select method
SelectAtPoint method
SelectByPolygon method
SelectOnScreen method
SetBulge method
SetGridSpacing method
SetInvisibleEdge method
SetPattern method
SetSnapSpacing method
SetVariable method
SetView method
SetWidth method
SetXData method
Split method
TransformBy method
UndefineFunction method
Unload method
Update method
WBlock method
ZoomAll method
ZoomCenter method
ZoomExtents method
ZoomPickWindow method
ZoomScaled method
ZoomWindow method
Constants
AcActiveSpace
AcAttachmentPoint
AcAttributeMode
AcColor
AcDimFractionType
AcDimHorizontalJustification
AcDimLUnits
AcDimPrecision
AcDimTextMovement
AcDimToleranceJustify
AcDimToleranceMethod
AcDimVerticalJustification
AcDrawingDirection
AcEntityName
AcExtendOption
AcHatchStyle
AcMenuGroupType
AcMenuItemType
AcPatternType
AcSaveAsType
AcHorizontalAlignment
AcLineWeight
AcPlotPaperUnits
AcPlotRotation
AcPlotScale
AcPlotType
AcRegenType
AcLeaderType
AcPlotOrientation
AcPolymeshType
AcPolylineType
AcSelect
AcTextGenerationFlag
AcTextFontStyle
AcToolBarItemType
AcUnits
AcVerticalAlignment
AcViewportScale
AcViewportSplitType
AcWindowState
AcZoomScaleType
VBA (Visual Basic for Applications)
Overview of automation
Using ActiveX Automation
Using the Object Model
Starting VBA
Inserting UserForms
Adding controls to a UserForm
Creating code
Using modules
Managing VBA projects
Running a VBA program
Events in BricsCAD VBA
BRX (BricsCAD Runtime eXtension)
.NET
Bricscad-DevRef-DotNet.chm::/BrxMgdDoc.hhc