|
Name |
Description |
|
AddContext
|
(Inherited from DBObject.) |
|
AddPersistentReactor
|
(Inherited from DBObject.) |
|
AddSubentityPaths
|
(Inherited from Entity.) |
|
ApplyPartialUndo
|
(Inherited from DBObject.) |
|
AssertNotifyEnabled
|
(Inherited from DBObject.) |
|
AssertReadEnabled
|
(Inherited from DBObject.) |
|
AssertWriteEnabled
|
(Inherited from DBObject.) |
|
Audit
|
(Inherited from DBObject.) |
|
BoundingBoxIntersectWith(Entity,
Intersect, Point3dCollection, Int32, Int32)
|
Obsolete. (Inherited from Entity.) |
|
BoundingBoxIntersectWith(Entity,
Intersect, Point3dCollection, IntPtr, IntPtr)
|
(Inherited from Entity.) |
|
BoundingBoxIntersectWith(Entity,
Intersect, Plane, Point3dCollection, Int32, Int32)
|
Obsolete. (Inherited from Entity.) |
|
BoundingBoxIntersectWith(Entity,
Intersect, Plane, Point3dCollection, IntPtr, IntPtr)
|
(Inherited from Entity.) |
|
Cancel
|
Obsolete. (Inherited from DBObject.) |
|
Clone
|
(Inherited from RXObject.) |
|
Close
|
Obsolete. (Inherited from DBObject.) |
|
CloseAndPage
|
Obsolete. (Inherited from DBObject.) |
|
CompareTo
|
(Inherited from RXObject.) |
|
ComputeSurfaceArea
|
|
|
ComputeVolume
|
|
|
ConvertToSolid
|
|
|
ConvertToSurface(Boolean,
Boolean)
|
|
|
ConvertToSurface(Boolean,
SubentityId)
|
|
|
CopyFrom
|
(Inherited from RXObject.) |
|
CreateExtensionDictionary
|
(Inherited from DBObject.) |
|
CreateObjRef
|
Creates an object that contains all the
relevant information required to generate a proxy used to
communicate with a remote object.
(Inherited from MarshalByRefObject.) |
|
DecomposeForSave
|
(Inherited from DBObject.) |
|
DeepClone
|
(Inherited from DBObject.) |
|
DeleteSubentityPaths
|
(Inherited from Entity.) |
|
DeleteUnmanagedObject
|
(Inherited from DBObject.) |
|
DisableUndoRecording
|
(Inherited from DBObject.) |
|
Dispose
|
(Inherited from DisposableWrapper.) |
|
Dispose(Boolean)
|
(Inherited from DBObject.) |
|
DowngradeOpen
|
(Inherited from DBObject.) |
|
DowngradeToNotify
|
(Inherited from DBObject.) |
|
Draw
|
(Inherited from Entity.) |
|
DwgIn
|
(Inherited from DBObject.) |
|
DwgInFields
|
(Inherited from DBObject.) |
|
DwgOut
|
(Inherited from DBObject.) |
|
DwgOutFields
|
(Inherited from DBObject.) |
|
DxfIn
|
(Inherited from DBObject.) |
|
DxfInFields
|
(Inherited from DBObject.) |
|
DxfOut
|
(Inherited from DBObject.) |
|
DxfOutFields
|
(Inherited from DBObject.) |
|
Equals
|
(Inherited from DisposableWrapper.) |
|
Erase
|
(Inherited from DBObject.) |
|
Erase(Boolean)
|
(Inherited from DBObject.) |
|
Explode
|
(Inherited from Entity.) |
|
ExplodeGeometry
|
(Inherited from Entity.) |
|
ExplodeGeometryToBlock(BlockTableRecord)
|
(Inherited from Entity.) |
|
ExplodeGeometryToBlock(BlockTableRecord,
ObjectIdCollection)
|
(Inherited from Entity.) |
|
ExplodeGeometryToOwnerSpace
|
(Inherited from Entity.) |
|
ExtrudeFaces(FullSubentityPath, Point3dCollection, Double)
|
|
|
ExtrudeFaces(FullSubentityPath, Double, Vector3d, Double)
|
|
|
Finalize
|
(Inherited from DisposableWrapper.) |
|
GetAdjacentSubentPath
|
|
|
GetCrease(FullSubentityPath)
|
|
|
GetCrease(SubentityId)
|
|
|
GetEventExtender
|
(Inherited from DBObject.) |
|
GetFacePlane
|
|
|
GetField
|
(Inherited from DBObject.) |
|
GetField(String)
|
(Inherited from DBObject.) |
|
GetGraphicsMarkersAtSubentityPathIntPtr
|
(Inherited from Entity.) |
|
GetGripPoints(Point3dCollection,
IntegerCollection, IntegerCollection)
|
(Inherited from Entity.) |
|
GetGripPoints(GripDataCollection,
Double, Int32, Vector3d, GetGripPointsFlags)
|
(Inherited from Entity.) |
|
GetGripPointsAtSubentityPath
|
(Inherited from Entity.) |
|
GetHashCode
|
(Inherited from DisposableWrapper.) |
|
GetLifetimeService
|
Retrieves the current lifetime service object
that controls the lifetime policy for this instance.
(Inherited from MarshalByRefObject.) |
|
GetNumberOfSubDividedFacesAt
|
|

|
GetObjectMesh
|
|
|
GetObjectSaveVersion(DwgFiler)
|
(Inherited from DBObject.) |
|
GetObjectSaveVersion(DxfFiler)
|
(Inherited from DBObject.) |
|
GetObjectSnapPoints(ObjectSnapModes,
Int32, Point3d, Point3d, Matrix3d, Point3dCollection,
IntegerCollection)
|
(Inherited from Entity.) |
|
GetObjectSnapPoints(ObjectSnapModes,
Int32, Point3d, Point3d, Matrix3d, Point3dCollection,
IntegerCollection, Matrix3d)
|
(Inherited from Entity.) |
|
GetPersistentReactorIds
|
(Inherited from DBObject.) |
|
GetPlane
|
(Inherited from Entity.) |
|
GetReactors
|
Obsolete. (Inherited from DBObject.) |
|
GetRXClass
|
(Inherited from RXObject.) |
|
GetStretchPoints
|
(Inherited from Entity.) |
|
GetSubDividedVertexAt(Int32)
|
|
|
GetSubDividedVertexAt(SubentityId)
|
|
|
GetSubentColor
|
|
|
GetSubentity
|
(Inherited from Entity.) |
|
GetSubentityGeometricExtents
|
(Inherited from Entity.) |
|
GetSubentityPathsAtGraphicsMarker(SubentityType,
IntPtr, Point3d, Matrix3d, ObjectId)
|
(Inherited from Entity.) |
|
GetSubentityPathsAtGraphicsMarker(SubentityType,
Int32, Point3d, Matrix3d, Int32, ObjectId)
|
Obsolete. (Inherited from Entity.) |
|
GetSubentMaterial
|
|
|
GetSubentMaterialMapper
|
|
|
GetSubentPath
|
|
|
GetTransformedCopy
|
(Inherited from Entity.) |
|
GetTransientReactors
|
(Inherited from DBObject.) |
|
GetType
|
Gets the Type of the current instance.
(Inherited from Object.) |
|
GetVertexAt(Int32)
|
|
|
GetVertexAt(SubentityId)
|
|
|
GetXDataForApplication
|
(Inherited from DBObject.) |
|
HandOverTo
|
(Inherited from DBObject.) |
|
HasContext
|
(Inherited from DBObject.) |
|
HasPersistentReactor
|
(Inherited from DBObject.) |
|
Highlight
|
(Inherited from Entity.) |
|
Highlight(FullSubentityPath,
Boolean)
|
(Inherited from Entity.) |
|
InitializeLifetimeService
|
Obtains a lifetime service object to control
the lifetime policy for this instance.
(Inherited from MarshalByRefObject.) |
|
IntersectWith(Entity,
Intersect, Point3dCollection, Int32, Int32)
|
Obsolete. (Inherited from Entity.) |
|
IntersectWith(Entity,
Intersect, Point3dCollection, IntPtr, IntPtr)
|
(Inherited from Entity.) |
|
IntersectWith(Entity,
Intersect, Plane, Point3dCollection, Int32, Int32)
|
Obsolete. (Inherited from Entity.) |
|
IntersectWith(Entity,
Intersect, Plane, Point3dCollection, IntPtr, IntPtr)
|
(Inherited from Entity.) |
|
IsContentSnappable
|
(Inherited from Entity.) |
|
JoinEntities
|
(Inherited from Entity.) |
|
JoinEntity
|
(Inherited from Entity.) |
|
List
|
(Inherited from Entity.) |
|
MemberwiseClone
|
Creates a shallow copy of the current Object.
(Inherited from Object.) |
|
MemberwiseClone(Boolean)
|
(Inherited from MarshalByRefObject.) |
|
MoveGripPointsAt(IntegerCollection,
Vector3d)
|
(Inherited from Entity.) |
|
MoveGripPointsAt(IntPtr, Vector3d, MoveGripPointsFlags)
|
(Inherited from Entity.) |
|
MoveGripPointsAtSubentityPaths
|
(Inherited from Entity.) |
|
MoveStretchPointsAt
|
(Inherited from Entity.) |
|
QueryX
|
(Inherited from RXObject.) |
|
RecordGraphicsModified
|
(Inherited from Entity.) |
|
ReleaseExtensionDictionary
|
(Inherited from DBObject.) |
|
RemoveContext
|
(Inherited from DBObject.) |
|
RemoveField
|
(Inherited from DBObject.) |
|
RemoveField(String)
|
(Inherited from DBObject.) |
|
RemoveField(ObjectId)
|
(Inherited from DBObject.) |
|
RemovePersistentReactor
|
(Inherited from DBObject.) |
|
ResetScaleDependentProperties
|
(Inherited from DBObject.) |
|
SaveAs
|
(Inherited from Entity.) |
|
SetAttributes
|
(Inherited from Drawable.) |
|
Setbox
|
|
|
SetCone
|
|
|
SetCrease(Double)
|
|
|
SetCrease(FullSubentityPath, Double)
|
|
|
SetCylinder
|
|
|
SetDatabaseDefaults
|
(Inherited from Entity.) |
|
SetDatabaseDefaults(Database)
|
(Inherited from Entity.) |
|
SetDragStatus
|
(Overrides EntitySetDragStatus(DragStatus).) |
|
SetField(Field)
|
(Inherited from DBObject.) |
|
SetField(String,
Field)
|
(Inherited from DBObject.) |
|
SetFromStyle
|
(Inherited from DBObject.) |
|
SetGripStatus
|
(Inherited from Entity.) |
|
SetLayerId
|
(Inherited from Entity.) |
|
SetObjectIdsInFlux
|
(Inherited from DBObject.) |
|
SetPaperOrientation
|
(Inherited from DBObject.) |
|
SetPropertiesFrom
|
(Inherited from Entity.) |
|
SetPyramid
|
|
|
SetSphere
|
|
|
SetSubDMesh
|
|
|
SetSubentColor
|
|
|
SetSubentityGripStatus
|
(Inherited from Entity.) |
|
SetSubentMaterial
|
|
|
SetSubentMaterialMapper
|
|
|
SetTorus
|
|
|
SetVertexAt(Int32,
Point3d)
|
|
|
SetVertexAt(SubentityId,
Point3d)
|
|
|
SetWedge
|
|
|
SplitFace
|
|
|
SubdDivideDown
|
|
|
SubdDivideUp
|
|
|
SubdRefine
|
|
|
SubdRefine(FullSubentityPath)
|
|
|
SubSetAttributes
|
(Inherited from DBObject.) |
|
SubViewportDraw
|
(Inherited from DBObject.) |
|
SubViewportDrawLogicalFlags
|
(Inherited from DBObject.) |
|
SubWorldDraw
|
(Inherited from DBObject.) |
|
SupportsCollection
|
(Inherited from DBObject.) |
|
SwapIdWith
|
(Inherited from DBObject.) |
|
SwapReferences
|
(Inherited from DBObject.) |
|
ToString
|
Returns a string that represents the current
object.
(Inherited from Object.) |
|
TransformBy
|
(Inherited from Entity.) |
|
TransformSubentityPathsBy
|
(Inherited from Entity.) |
|
Unhighlight
|
(Inherited from Entity.) |
|
Unhighlight(FullSubentityPath,
Boolean)
|
(Inherited from Entity.) |
|
UpgradeFromNotify
|
(Inherited from DBObject.) |
|
UpgradeOpen
|
(Inherited from DBObject.) |
|
ViewportDraw
|
(Inherited from Drawable.) |
|
ViewportDrawLogicalFlags
|
(Inherited from Drawable.) |
|
WblockClone
|
(Inherited from DBObject.) |
|
WorldDraw
|
(Inherited from Drawable.) |
|
X
|
(Inherited from RXObject.) |
|
XDataTransformBy
|
(Inherited from DBObject.) |