BlockReference Class |
The BlockReference type exposes the following members.
Name | Description | |
---|---|---|
![]() |
BlockReference |
Constructor. Creates a new BlockReference
object for a block table record at the specified position.
|
Name | Description | |
---|---|---|
![]() |
AcadObject | (Inherited from DBObject.) |
![]() |
Annotative | (Inherited from DBObject.) |
![]() |
AnonymousBlockTableRecord |
Gets the ObjectID of the anonymous block
BlockTableRecord used to draw the dynamic block.
|
![]() |
AttributeCollection |
Gets the attribute collection for this
BlockReference.
|
![]() |
AutoDelete | (Inherited from DisposableWrapper.) |
![]() |
BlockId | (Inherited from Entity.) |
![]() |
BlockName | (Inherited from Entity.) |
![]() |
BlockTableRecord |
Gets the ObjectID of the BlockTableRecord
associated with this BlockReference.
|
![]() |
BlockTransform |
Gets the transformation matrix mapping a point
in the MCS to the WCS.
|
![]() |
BlockUnit |
Gets or sets the units associated with the
block.
|
![]() |
Bounds | (Inherited from Drawable.) |
![]() |
CastShadows | (Inherited from Entity.) |
![]() |
ClassID | (Inherited from DBObject.) |
![]() |
CloneMeForDragging | (Inherited from Entity.) |
![]() |
CollisionType | (Inherited from Entity.) |
![]() |
Color | (Inherited from Entity.) |
![]() |
ColorIndex | (Inherited from Entity.) |
![]() |
CompoundObjectTransform | (Inherited from Entity.) |
![]() |
Database | (Inherited from DBObject.) |
![]() |
Drawable | (Inherited from DBObject.) |
![]() |
DrawableType | (Inherited from Drawable.) |
![]() |
DynamicBlockReferencePropertyCollection |
Gets the collection of the dynamic block
reference properties if the block reference is a dynamic
block.
|
![]() |
DynamicBlockTableRecord |
Gets the ObjectID of the dynamic block table
record associated with this block reference, if the block reference
is a dynamic block.
|
![]() |
Ecs | (Inherited from Entity.) |
![]() |
EdgeStyleId | (Inherited from Entity.) |
![]() |
EntityColor | (Inherited from Entity.) |
![]() |
ExtensionDictionary | (Inherited from DBObject.) |
![]() |
FaceStyleId | (Inherited from Entity.) |
![]() |
ForceAnnoAllVisible | (Inherited from Entity.) |
![]() |
GeometricExtents | (Inherited from Entity.) |
![]() |
Handle | (Inherited from DBObject.) |
![]() |
HasFields | (Inherited from DBObject.) |
![]() |
HasSaveVersionOverride | (Inherited from DBObject.) |
![]() |
Hyperlinks | (Inherited from Entity.) |
![]() |
Id | (Inherited from DBObject.) |
![]() |
IsAProxy | (Inherited from DBObject.) |
![]() |
IsCancelling | (Inherited from DBObject.) |
![]() |
IsDisposed | (Inherited from DisposableWrapper.) |
![]() |
IsDynamicBlock |
Gets whether the block reference is a dynamic
block.
|
![]() |
IsErased | (Inherited from DBObject.) |
![]() |
IsEraseStatusToggled | (Inherited from DBObject.) |
![]() |
IsModified | (Inherited from DBObject.) |
![]() |
IsModifiedGraphics | (Inherited from DBObject.) |
![]() |
IsModifiedXData | (Inherited from DBObject.) |
![]() |
IsNewObject | (Inherited from DBObject.) |
![]() |
IsNotifyEnabled | (Inherited from DBObject.) |
![]() |
IsNotifying | (Inherited from DBObject.) |
![]() |
IsObjectIdsInFlux | (Inherited from DBObject.) |
![]() |
IsPersistent | (Inherited from DBObject.) |
![]() |
IsPlanar | (Inherited from Entity.) |
![]() |
IsReadEnabled | (Inherited from DBObject.) |
![]() |
IsReallyClosing | (Inherited from DBObject.) |
![]() |
IsTransactionResident | (Inherited from DBObject.) |
![]() |
IsUndoing | (Inherited from DBObject.) |
![]() |
IsWriteEnabled | (Inherited from DBObject.) |
![]() |
Layer | (Inherited from Entity.) |
![]() |
LayerId | (Inherited from Entity.) |
![]() |
Linetype | (Inherited from Entity.) |
![]() |
LinetypeId | (Inherited from Entity.) |
![]() |
LinetypeScale | (Inherited from Entity.) |
![]() |
LineWeight | (Inherited from Entity.) |
![]() |
Material | (Inherited from Entity.) |
![]() |
MaterialId | (Inherited from Entity.) |
![]() |
MaterialMapper | (Inherited from Entity.) |
![]() |
MergeStyle | (Inherited from DBObject.) |
![]() |
Name |
Gets the name of the BlockTableRecord object
associated with this BlockReference.
|
![]() |
Normal |
Gets or sets the normal (in WCS coordinates)
for the plane of this block reference.
|
![]() |
ObjectBirthVersion | (Inherited from DBObject.) |
![]() |
ObjectId | (Inherited from DBObject.) |
![]() |
OwnerId | (Inherited from DBObject.) |
![]() |
PaperOrientation | (Inherited from DBObject.) |
![]() |
PlotStyleName | (Inherited from Entity.) |
![]() |
PlotStyleNameId | (Inherited from Entity.) |
![]() |
Position |
Gets or sets the insertion point (in WCS
coordinates) of this block reference.
|
![]() |
ReceiveShadows | (Inherited from Entity.) |
![]() |
Rotation |
Gets or sets the rotation angle (in radians)
of this block reference.
|
![]() |
ScaleFactors |
Gets or sets the the scale factors of this
block reference.
|
![]() |
Transparency | (Inherited from Entity.) |
![]() |
TreatAsBlockRefForExplode | |
![]() |
UndoFiler | (Inherited from DBObject.) |
![]() |
UnitFactor |
Gets the unit factor.
|
![]() |
UnmanagedObject | (Inherited from DisposableWrapper.) |
![]() |
Visible | (Inherited from Entity.) |
![]() |
VisualStyleId | (Inherited from Entity.) |
![]() |
XData | (Inherited from DBObject.) |
Name | Description | |
---|---|---|
![]() |
Cancelled | (Inherited from DBObject.) |
![]() |
Copied | (Inherited from DBObject.) |
![]() |
Erased | (Inherited from DBObject.) |
![]() |
Goodbye | (Inherited from DBObject.) |
![]() |
Modified | (Inherited from DBObject.) |
![]() |
ModifiedXData | (Inherited from DBObject.) |
![]() |
ModifyUndone | (Inherited from DBObject.) |
![]() |
ObjectClosed | (Inherited from DBObject.) |
![]() |
OpenedForModify | (Inherited from DBObject.) |
![]() |
Reappended | (Inherited from DBObject.) |
![]() |
SubObjectModified | (Inherited from DBObject.) |
![]() |
Unappended | (Inherited from DBObject.) |
© Bricsys NV. All rights reserved. |