Ellipse Class

Inheritance Hierarchy
Namespace:  Teigha.DatabaseServices
Assembly:  TD_Mgd (in TD_Mgd.dll) Version: 21.4.0.0
Syntax
public class Ellipse : Curve

The Ellipse type exposes the following members.

Constructors
  Name Description
Public method Ellipse
Initializes a new instance of the Ellipse class
Protected method Ellipse(IntPtr, Boolean)
Initializes a new instance of the Ellipse class
Public method Ellipse(Point3d, Vector3d, Vector3d, Double, Double, Double)
Initializes a new instance of the Ellipse class
Top
Properties
  Name Description
Public property Center
Public property EndAngle
Public property EndParam (Overrides CurveEndParam.)
Public property IsNull
Public property MajorAxis
Public property MajorRadius
Public property MinorAxis
Public property MinorRadius
Public property Normal
Public property RadiusRatio
Public property StartAngle
Public property StartParam (Overrides CurveStartParam.)
Top
Methods
  Name Description
Public method GetAngleAtParameter
Public method GetParameterAtAngle
Public method Set
Top
Events
  Name Description
Top
See Also

©  Bricsys NV. All rights reserved.