Editor Class

Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Bricscad.EditorInputEditor

Namespace: Bricscad.EditorInput
Assembly: BrxMgd (in BrxMgd.dll) Version: 24.0.1.0
Syntax
public sealed class Editor : MarshalByRefObject, 
        IDisposable

The Editor type exposes the following members.

Properties
Methods
  Name Description
Public method ClearVectors  
Public method Command  
Public method CommandAsync  
Public method Dispose Releases all resources used by the Editor
Public method DoPrompt  
Public method Drag(Jig)  
Public method Drag(PromptDragOptions)  
Public method Drag(SelectionSet, String, DragCallback)  
Public method DrawVector  
Public method DrawVectors  
Public method GetAngle(PromptAngleOptions)  
Public method GetAngle(String)  
Public method GetCorner(PromptCornerOptions)  
Public method GetCorner(String, Point3d)  
Public method GetCurrentView  
Public method GetDistance(PromptDistanceOptions)  
Public method GetDistance(String)  
Public method GetDouble(PromptDoubleOptions)  
Public method GetDouble(String)  
Public method GetEntity(PromptEntityOptions)  
Public method GetEntity(String)  
Public method GetFileNameForOpen(PromptOpenFileOptions)  
Public method GetFileNameForOpen(String)  
Public method GetFileNameForSave(PromptSaveFileOptions)  
Public method GetFileNameForSave(String)  
Public method GetInteger(PromptIntegerOptions)  
Public method GetInteger(String)  
Public method GetKeywords(PromptKeywordOptions)  
Public method GetKeywords(String, String)  
Public method GetNestedEntity(PromptNestedEntityOptions)  
Public method GetNestedEntity(String)  
Public method GetPoint(PromptPointOptions)  
Public method GetPoint(String)  
Public method GetSelection  
Public method GetSelection(PromptSelectionOptions)  
Public method GetSelection(SelectionFilter)  
Public method GetSelection(PromptSelectionOptions, SelectionFilter)  
Public method GetString(PromptStringOptions)  
Public method GetString(String)  
Public method GetViewportNumber  
Public method PointToScreen  
Public method PointToWorld(Point)  
Public method PointToWorld(Point, Int32)  
Public method Regen  
Public method SelectAll  
Public method SelectAll(SelectionFilter)  
Public method SelectCrossingPolygon(Point3dCollection)  
Public method SelectCrossingPolygon(Point3dCollection, SelectionFilter)  
Public method SelectCrossingWindow(Point3d, Point3d)  
Public method SelectCrossingWindow(Point3d, Point3d, SelectionFilter)  
Public method SelectFence(Point3dCollection)  
Public method SelectFence(Point3dCollection, SelectionFilter)  
Public method SelectImplied  
Public method SelectLast  
Public method SelectPrevious  
Public method SelectWindow(Point3d, Point3d)  
Public method SelectWindow(Point3d, Point3d, SelectionFilter)  
Public method SelectWindowPolygon(Point3dCollection)  
Public method SelectWindowPolygon(Point3dCollection, SelectionFilter)  
Public method SetCurrentView  
Public method SetImpliedSelection(ObjectId)  
Public method SetImpliedSelection(SelectionSet)  
Public method Snap  
Public method StartUserInteraction(Control)  
Public method StartUserInteraction(IntPtr)  
Public method StartUserInteraction(Window)  
Public method SwitchToModelSpace  
Public method SwitchToPaperSpace  
Public method TraceBoundary(Point3d, IslandDetectionDepth)  
Public method TraceBoundary(Point3d, Boolean)  
Public method TurnForcedPickOff  
Public method TurnForcedPickOn  
Public method UpdateScreen  
Public method UpdateTiledViewportsFromDatabase  
Public method UpdateTiledViewportsInDatabase  
Public method WriteMessage(String)  
Public method WriteMessage(String, Object)  
Top
Events
Fields
  Name Description
Public fieldStatic member PauseToken  
Top
See Also

©  Bricsys NV. All rights reserved.