LayoutHelperDevice Class

This class represents a layout helper device.
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.RuntimeRXObject
        Teigha.GraphicsSystemDevice
          Teigha.GraphicsSystemImpDevice
            Teigha.GraphicsSystemLayoutHelperDevice

Namespace: Teigha.GraphicsSystem
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public class LayoutHelperDevice : ImpDevice

The LayoutHelperDevice type exposes the following members.

Properties
  Name Description
Public property ActiveView Property that represents an active View object of the layout associated with this object.
Public property LayoutId Property that represents a persistent object identifier of an associated layout.
Public property Model Property that represents a model associated with this object.
Public property UnderlyingDevice Property that represents an underlying Device object associated with this object.
Top
Methods
  Name Description
Public method ActivateViewport(ObjectId) Sets the active viewport.
Public method ActivateViewport(Point2d) Sets the active viewport.
Public method MakeViewActive Sets the active View object of the layout associated with this object.
Public methodStatic member SetupActiveLayoutViews Sets active Gs views for a specified device according to the active database's layout data.
Public methodStatic member SetupLayoutViews Sets Gs views for a specified device according to the specified database layout data.
Top
See Also

©  Bricsys NV. All rights reserved.