AttributeReference Class |
The AttributeReference type exposes the following members.
Name | Description | |
---|---|---|
![]() |
AttributeReference |
Default constructor.
|
![]() |
AttributeReference(Point3d, String, String, ObjectId) |
Builds a new instance of the
AttributeReference class with specified parameters.
|
Name | Description | |
---|---|---|
![]() |
AcadObject | (Inherited from DBObject.) |
![]() |
AlignmentPoint | (Inherited from DBText.) |
![]() |
Annotative | (Inherited from DBObject.) |
![]() |
AutoDelete | (Inherited from DisposableWrapper.) |
![]() |
BlockId | (Inherited from Entity.) |
![]() |
BlockName | (Inherited from Entity.) |
![]() |
Bounds | (Inherited from Drawable.) |
![]() |
CastShadows | (Inherited from Entity.) |
![]() |
ClassID | (Inherited from DBObject.) |
![]() |
CloneMeForDragging | (Inherited from Entity.) |
![]() |
CollisionType | (Inherited from Entity.) |
![]() |
Color | (Inherited from Entity.) |
![]() |
ColorIndex | (Inherited from Entity.) |
![]() |
CompoundObjectTransform | (Inherited from Entity.) |
![]() |
Database | (Inherited from DBObject.) |
![]() |
Drawable | (Inherited from DBObject.) |
![]() |
DrawableType | (Inherited from Drawable.) |
![]() |
Ecs | (Inherited from Entity.) |
![]() |
EdgeStyleId | (Inherited from Entity.) |
![]() |
EntityColor | (Inherited from Entity.) |
![]() |
ExtensionDictionary | (Inherited from DBObject.) |
![]() |
FaceStyleId | (Inherited from Entity.) |
![]() |
FieldLength |
Gets or sets the field length of this
AttributeReference object.
|
![]() |
ForceAnnoAllVisible | (Inherited from Entity.) |
![]() |
GeometricExtents | (Inherited from Entity.) |
![]() |
Handle | (Inherited from DBObject.) |
![]() |
HasFields | (Inherited from DBObject.) |
![]() |
HasSaveVersionOverride | (Inherited from DBObject.) |
![]() |
Height | (Inherited from DBText.) |
![]() |
HorizontalMode | (Inherited from DBText.) |
![]() |
Hyperlinks | (Inherited from Entity.) |
![]() |
Id | (Inherited from DBObject.) |
![]() |
Invisible |
Gets or sets whether this AttributeReference
object is invisible. If true, then the entity is invisible.
|
![]() |
IsAProxy | (Inherited from DBObject.) |
![]() |
IsCancelling | (Inherited from DBObject.) |
![]() |
IsConstant |
Gets whether this AttributeReference object is
constant. If true, then the entity is constant.
|
![]() |
IsDefaultAlignment | (Inherited from DBText.) |
![]() |
IsDisposed | (Inherited from DisposableWrapper.) |
![]() |
IsErased | (Inherited from DBObject.) |
![]() |
IsEraseStatusToggled | (Inherited from DBObject.) |
![]() |
IsMirroredInX | (Inherited from DBText.) |
![]() |
IsMirroredInY | (Inherited from DBText.) |
![]() |
IsModified | (Inherited from DBObject.) |
![]() |
IsModifiedGraphics | (Inherited from DBObject.) |
![]() |
IsModifiedXData | (Inherited from DBObject.) |
![]() |
IsMTextAttribute |
Gets or sets whether this AttributeReference
object is a multiline attribute.
|
![]() |
IsNewObject | (Inherited from DBObject.) |
![]() |
IsNotifyEnabled | (Inherited from DBObject.) |
![]() |
IsNotifying | (Inherited from DBObject.) |
![]() |
IsObjectIdsInFlux | (Inherited from DBObject.) |
![]() |
IsPersistent | (Inherited from DBObject.) |
![]() |
IsPlanar | (Inherited from Entity.) |
![]() |
IsPreset |
Gets the preset status of this
AttributeReference object. If true, then the entity is set to be
preset.
|
![]() |
IsReadEnabled | (Inherited from DBObject.) |
![]() |
IsReallyClosing | (Inherited from DBObject.) |
![]() |
IsTransactionResident | (Inherited from DBObject.) |
![]() |
IsUndoing | (Inherited from DBObject.) |
![]() |
IsVerifiable |
Gets or sets the verifiable status of this
AttributeReference object. If true, then the entity is set to be
verifiable.
|
![]() |
IsWriteEnabled | (Inherited from DBObject.) |
![]() |
Justify | (Inherited from DBText.) |
![]() |
Layer | (Inherited from Entity.) |
![]() |
LayerId | (Inherited from Entity.) |
![]() |
Linetype | (Inherited from Entity.) |
![]() |
LinetypeId | (Inherited from Entity.) |
![]() |
LinetypeScale | (Inherited from Entity.) |
![]() |
LineWeight | (Inherited from Entity.) |
![]() |
LockPositionInBlock |
Gets or sets whether the position of this
AttributeReference object is fixed in the block. If true, then the
attribute can't be moved relative to the geometry.
|
![]() |
Material | (Inherited from Entity.) |
![]() |
MaterialId | (Inherited from Entity.) |
![]() |
MaterialMapper | (Inherited from Entity.) |
![]() |
MergeStyle | (Inherited from DBObject.) |
![]() |
MTextAttribute |
Gets or sets the MText enity that represents
the multiline attribute.
|
![]() |
Normal | (Inherited from DBText.) |
![]() |
ObjectBirthVersion | (Inherited from DBObject.) |
![]() |
ObjectId | (Inherited from DBObject.) |
![]() |
Oblique | (Inherited from DBText.) |
![]() |
OwnerId | (Inherited from DBObject.) |
![]() |
PaperOrientation | (Inherited from DBObject.) |
![]() |
PlotStyleName | (Inherited from Entity.) |
![]() |
PlotStyleNameId | (Inherited from Entity.) |
![]() |
Position | (Inherited from DBText.) |
![]() |
ReceiveShadows | (Inherited from Entity.) |
![]() |
Rotation | (Inherited from DBText.) |
![]() |
Tag |
Gets or sets the tag string of this
AttributeReference object.
|
![]() |
TextString | (Inherited from DBText.) |
![]() |
TextStyleId | (Inherited from DBText.) |
![]() |
TextStyleName | (Inherited from DBText.) |
![]() |
Thickness | (Inherited from DBText.) |
![]() |
Transparency | (Inherited from Entity.) |
![]() |
UndoFiler | (Inherited from DBObject.) |
![]() |
UnmanagedObject | (Inherited from DisposableWrapper.) |
![]() |
VerticalMode | (Inherited from DBText.) |
![]() |
Visible | (Inherited from Entity.) |
![]() |
VisualStyleId | (Inherited from Entity.) |
![]() |
WidthFactor | (Inherited from DBText.) |
![]() |
XData | (Inherited from DBObject.) |
Name | Description | |
---|---|---|
![]() |
Cancelled | (Inherited from DBObject.) |
![]() |
Copied | (Inherited from DBObject.) |
![]() |
Erased | (Inherited from DBObject.) |
![]() |
Goodbye | (Inherited from DBObject.) |
![]() |
Modified | (Inherited from DBObject.) |
![]() |
ModifiedXData | (Inherited from DBObject.) |
![]() |
ModifyUndone | (Inherited from DBObject.) |
![]() |
ObjectClosed | (Inherited from DBObject.) |
![]() |
OpenedForModify | (Inherited from DBObject.) |
![]() |
Reappended | (Inherited from DBObject.) |
![]() |
SubObjectModified | (Inherited from DBObject.) |
![]() |
Unappended | (Inherited from DBObject.) |
© Bricsys NV. All rights reserved. |