OffsetCurve2d Class |
The OffsetCurve2d type exposes the following members.
Name | Description | |
---|---|---|
![]() |
OffsetCurve2d |
Initializes a new instance of the OffsetCurve2d class
|
Name | Description | |
---|---|---|
![]() |
AutoDelete | (Inherited from DisposableWrapper.) |
![]() |
BoundBlock | (Inherited from Curve2d.) |
![]() |
Curve | |
![]() |
EndPoint | (Inherited from Curve2d.) |
![]() |
HasEndPoint | (Inherited from Curve2d.) |
![]() |
HasStartPoint | (Inherited from Curve2d.) |
![]() |
IsDisposed | (Inherited from DisposableWrapper.) |
![]() |
OffsetDistance | |
![]() |
OrthoBoundBlock | (Inherited from Curve2d.) |
![]() |
ParameterDirection | |
![]() |
StartPoint | (Inherited from Curve2d.) |
![]() |
Transformation | |
![]() |
UnmanagedObject | (Inherited from DisposableWrapper.) |
Name | Description | |
---|---|---|
![]() |
Clone | (Inherited from Entity2d.) |
![]() ![]() |
Create | |
![]() |
CreateObjRef |
Creates an object that contains all the
relevant information required to generate a proxy used to
communicate with a remote object.
(Inherited from MarshalByRefObject.) |
![]() |
Dispose | (Inherited from DisposableWrapper.) |
![]() |
Equals | (Inherited from DisposableWrapper.) |
![]() |
EvaluatePoint |
Retrieves the point on the curve corresponding
to the specified parameter value.
(Inherited from Curve2d.) |
![]() |
Explode |
Explodes the curve into its component
sub-curves.
(Inherited from Curve2d.) |
![]() |
GetArea(Double, Double) |
Retrieves the area of the parametric interval
defined by the passed start and end parameters.
(Inherited from Curve2d.) |
![]() |
GetArea(Double, Double, Tolerance) |
Retrieves the area of the parametric interval
defined by the passed start and end parameters within the specified
tolerance.
(Inherited from Curve2d.) |
![]() |
GetBoundBlockOf |
Retrieves the oriented bounding box of the
specified parametric interval of this curve.
(Inherited from Curve2d.) |
![]() |
GetClosestPointTo(Curve2d) |
Retrieves the closest points between this
curve and the passed curve.
(Inherited from Curve2d.) |
![]() |
GetClosestPointTo(Point2d) |
Retrieves the closest point on this curve to
the specified point.
(Inherited from Curve2d.) |
![]() |
GetClosestPointTo(Curve2d, Tolerance) |
Retrieves the closest points between this
curve and the passed curve within a specified tolerance.
(Inherited from Curve2d.) |
![]() |
GetClosestPointTo(Point2d, Tolerance) |
Retrieves the closest point on this curve to
the specified point within the specified tolerance.
(Inherited from Curve2d.) |
![]() |
GetDistanceTo(Curve2d) |
Retrieves the distance of the closest points
between this curve and the passed curve.
(Inherited from Curve2d.) |
![]() |
GetDistanceTo(Point2d) |
Retrieves the distance of the closest point on
this curve and the specified point.
(Inherited from Curve2d.) |
![]() |
GetDistanceTo(Curve2d, Tolerance) |
Retrieves the distance of the closest points
between this curve and the passed curve within a specified
tolerance.
(Inherited from Curve2d.) |
![]() |
GetDistanceTo(Point2d, Tolerance) |
Retrieves the distance of the closest point on
this curve and the specified point within a specified
tolerance.
(Inherited from Curve2d.) |
![]() |
GetHashCode | (Inherited from DisposableWrapper.) |
![]() |
GetInterval |
Retrieves the parametric interval of this
curve.
(Inherited from Curve2d.) |
![]() |
GetLength(Double, Double) |
Retrieves the arc length of the curve between
the two parameter values.
(Inherited from Curve2d.) |
![]() |
GetLength(Double, Double, Tolerance) |
Retrieves the arc length of the curve between
the two parameter values within a specified tolerance.
(Inherited from Curve2d.) |
![]() |
GetLifetimeService |
Retrieves the current lifetime service object
that controls the lifetime policy for this instance.
(Inherited from MarshalByRefObject.) |
![]() |
GetNormalPoint(Point2d) |
Retrieves the point on this curve where normal
extends through the passed point.
(Inherited from Curve2d.) |
![]() |
GetNormalPoint(Point2d, Tolerance) |
Retrieves the point on this curve where normal
extends through the passed point within the specified
tolerance.
(Inherited from Curve2d.) |
![]() |
GetOrthoBoundBlockOf |
Retrieves the bounding box of the specified
parametric range of this curve. Bounding box sides are parallel to
the coordinate axes.
(Inherited from Curve2d.) |
![]() |
GetParameterAtLength(Double, Double, Boolean) |
Retrieves the parameter value of the point
whose arc length distance is the input length.
(Inherited from Curve2d.) |
![]() |
GetParameterAtLength(Double, Double, Boolean, Tolerance) |
Retrieves the parameter value of the point
whose arc length distance is the input length.
(Inherited from Curve2d.) |
![]() |
GetParameterOf(Point2d) |
Retrieves the parameter value of a
point.
(Inherited from Curve2d.) |
![]() |
GetParameterOf(Point2d, Tolerance) |
Retrieves the parameter value of a point
within a specified tolerance.
(Inherited from Curve2d.) |
![]() |
GetReverseParameterCurve |
Reverses the parameter direction for this
curve.
(Inherited from Curve2d.) |
![]() |
GetSamplePoints(Int32) |
Retrieves an array of sample points along this
curve.
(Inherited from Curve2d.) |
![]() |
GetSamplePoints(Double, Double, Double) |
Retrieves specified arrays of sample points
along this curve and their parameter values.
(Inherited from Curve2d.) |
![]() |
GetSplitCurves |
Retrieves two segments of this curve split at
the specified parameter value.
(Inherited from Curve2d.) |
![]() |
GetTrimmedOffset(Double, OffsetCurveExtensionType) |
Retrieves offset curves that represent the
trimmed offset of the curve.
(Inherited from Curve2d.) |
![]() |
GetTrimmedOffset(Double, OffsetCurveExtensionType, Tolerance) |
Retrieves one or more offset curves that
represent the trimmed offset of the curve.
(Inherited from Curve2d.) |
![]() |
GetType |
Gets the Type of the current instance.
(Inherited from Object.) |
![]() |
InitializeLifetimeService |
Obtains a lifetime service object to control
the lifetime policy for this instance.
(Inherited from MarshalByRefObject.) |
![]() |
IsClosed |
Checks whether the curve is closed.
(Inherited from Curve2d.) |
![]() |
IsClosed(Tolerance) |
Checks whether the curve is closed within a
specified tolerance.
(Inherited from Curve2d.) |
![]() |
IsDegenerate(Entity2d) |
Checks whether this curve is degenerate and
returns the type of entity that the curve degenerates to (if
degenerate).
(Inherited from Curve2d.) |
![]() |
IsDegenerate(Entity2d, Tolerance) |
Checks whether this curve is degenerate and
returns the type of entity that the curve degenerates to (if
degenerate).
(Inherited from Curve2d.) |
![]() |
IsEqualTo(Entity2d) | (Inherited from Entity2d.) |
![]() |
IsEqualTo(Entity2d, Tolerance) | (Inherited from Entity2d.) |
![]() |
IsLinear(Line2d) |
Checks whether this curve is linear.
(Inherited from Curve2d.) |
![]() |
IsLinear(Line2d, Tolerance) |
Checks whether this curve is linear within a
specified tolerance.
(Inherited from Curve2d.) |
![]() |
IsOn(Double) |
Checks whether a specified parameter value is
within a valid parametric range of the curve.
(Inherited from Curve2d.) |
![]() |
IsOn(Point2d) |
Checks whether a specified point lies on this
curve.
(Inherited from Curve2d.) |
![]() |
IsOn(Double, Tolerance) |
Checks whether a specified parameter value is
within a parametric range of the curve.
(Inherited from Curve2d.) |
![]() |
IsOn(Point2d, Double) |
Checks whether a specified point lies on this
curve.
(Inherited from Curve2d.) |
![]() |
IsOn(Point2d, Tolerance) |
Checks whether a specified point lies on this
curve within specified tolerance.
(Inherited from Curve2d.) |
![]() |
IsOn(Point2d, Double, Tolerance) |
Checks whether a specified point lies on this
curve.
(Inherited from Curve2d.) |
![]() |
IsPeriodic |
Checks whether the curve is periodic.
(Inherited from Curve2d.) |
![]() |
Mirror | (Inherited from Entity2d.) |
![]() |
RotateBy | (Inherited from Entity2d.) |
![]() |
ScaleBy | (Inherited from Entity2d.) |
![]() |
SetInterval |
Sets the parametric range of this curve.
(Inherited from Curve2d.) |
![]() |
ToString |
Returns a string that represents the current
object.
(Inherited from Object.) |
![]() |
TransformBy | (Inherited from Entity2d.) |
![]() |
TranslateBy | (Inherited from Entity2d.) |
© Bricsys NV. All rights reserved. |