ExternalCurve3d Class

This class wraps the OdGeExternalCurve3d class which represents 3D curves, whose definitions are external to this library and the OdGe library.
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.GeometryEntity3d
        Teigha.GeometryCurve3d
          Teigha.GeometryExternalCurve3d

Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public sealed class ExternalCurve3d : Curve3d

The ExternalCurve3d type exposes the following members.

Constructors
  Name Description
Public method ExternalCurve3d Default constructor for the ExternalCurve3d class. Creates a default corresponding C++ object with a pointer to the curve definition set to NULL, undefined entity for a curve type (no information about the system that created an external curve in other words) and an option to prevent creating a copy of the external curve.
Top
Properties
  Name Description
Public property ExternalCurve  
Public property ExternalCurveKind  
Public property IsCircularArc  
Public property IsDefined  
Public property IsEllipticalArc  
Public property IsLine  
Public property IsLineSegment  
Public property IsNativeCurve  
Public property IsNurbCurve  
Public property IsOwnerOfCurve  
Public property IsRay  
Public property NativeCurve  
Top
Methods
  Name Description
Public methodStatic member Create Creates an object based on the passed pointer and returns a handle to the created object.
Public method Set Sets the parameters for this external curve according to the arguments.
Public method SetToOwnCurve Forces this external curve to own the data.
Top
Remarks
OdGeExternalCurve3d instances can be treated as any other OdGeCurve3d. You can access the OdGeExternalCurve3d as a corresponding native OdGeCurve3d, if such a corresponding curve exists, or you may (more efficiently) access the external data in its native form. One example of using OdGeExternalCurve3d is to access an ACIS curve.
See Also

©  Bricsys NV. All rights reserved.