DxfFiler Class

This class is the abstract base class for classes that are used for file I/O operations with the .dxf file format.
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.RuntimeRXObject
        Teigha.DatabaseServicesDxfFiler

Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public abstract class DxfFiler : RXObject

The DxfFiler type exposes the following members.

Constructors
  Name Description
Protected method DxfFiler Initializes a new instance of the DxfFiler class
Protected method DxfFiler(IntPtr, Boolean) Initializes a new instance of the DxfFiler class
Top
Properties
  Name Description
Public property AtEmbeddedObjectStart  
Public property AtEndOfFile Property that indicates whether this Filer object is at the end of file.
Public property AtEndOfObject Property that indicates whether this Filer object is at the end of an object's data.
Public property AtExtendedData Property that indicates whether this Filer object is at the start of an object's xdata.
Public property Database Property that represents a database associated with this filer.
Public property DwgVersion Property that represents the drawing version.
Public property Elevation  
Public property ErrorMessage  
Public property FilerStatus Property that represents the current status of this Filer object.
Public property FilerType Property that represents the type of this Filer object.
Public property IncludesDefaultValues  
Public property IsModifyingExistingObject  
Public property Position Property that represents the current I/O pointer position of this Filer object.
Public property Precision Property that represents the number of decimal digits written to ASCII DXF files in the range 0 to 16.
Public property Thickness  
Top
Methods
  Name Description
Public method AtSubclassData Checks whether this Filer object is at a subclass data marker with the specified subclass name as the passed value parameter.
Public method HaltAtClassBoundaries  
Public method PushBackItem Resets this Filer object to where it was before the last item was read.
Public method ReadAngle Returns the angle value from this Filer object.
Public method ReadBoolean Returns the Boolean value of the current item of this Filer object.
Public method ReadByte Returns the UInt8 value of the current item of this Filer object.
Public method ReadBytes Returns the specified number of bytes from this Filer object.
Public method ReadDouble Returns the double value from this Filer object.
Public method ReadHandle Returns the handle value from this Filer object.
Public method ReadInt16 Returns the Int16 value from this Filer object.
Public method ReadInt32 Returns the Int32 value from this Filer object.
Public method ReadInt64 Returns the Int64 value from this Filer object.
Public method ReadObjectId Returns the object ID from this Filer object.
Public method ReadPoint2d Returns the 2D point from this Filer object.
Public method ReadPoint3d Returns the 3D point from this Filer object.
Public method ReadResultBuffer Reads the next item of this Filer object, and returns the resulting buffer.
Public method ReadScale3d Returns the scale value from this Filer object.
Public method ReadString Returns the string value from this Filer object.
Public method ReadUInt16 Returns the UInt16 value from this Filer object.
Public method ReadUInt32 Returns the UInt32 value from this Filer object.
Public method ReadUInt64 Returns the UInt64 value from this Filer object.
Public method ReadVector2d Returns the 2D vector from this Filer object.
Public method ReadVector3d Returns the 3D vector from this Filer object.
Public method ResetFilerStatus Resets the current status of this Filer object.
Public method RewindFiler Resets the filer to its default condition without changing the position that the filer is pointing to its data.
Public method Seek Moves the I/O pointer to the specified location in this Filer object.
Public method SetError(String, String) Prints the error message represented by the provided string format, using the passed parameters. Currently not implemented.
Public method SetError(ErrorStatus, String, String) Prints the error message represented by the provided string format, using the passed parameters. Currently not implemented.
Public method WriteAngle Writes the specified angle value to this Filer object.
Public method WriteBoolean Writes the specified Boolean value to this Filer object.
Public method WriteByte Writes the specified byte to this Filer object.
Public method WriteBytes Writes the specified number of bytes to this Filer object.
Public method WriteDouble Writes the specified double value to this Filer object.
Public method WriteEmbeddedObjectStart Writes a string data value of "Embedded Object" for the DxfCode.EmbeddedObjectStart group code.
Public method WriteHandle Writes the specified handle value to this Filer object.
Public method WriteInt16 Writes the specified Int16 value to this Filer object.
Public method WriteInt32 Writes the specified Int32 value to this Filer object.
Public method WriteInt64 Writes the specified Int64 value to this Filer object.
Public method WriteName Writes the specified name (string value) to this Filer object.
Public method WriteObjectId Writes the specified object identifier to this Filer object.
Public method WritePoint2d Writes the specified 2D point to this Filer object.
Public method WritePoint3d Writes the specified 3D point to this Filer object.
Public method WriteResultBuffer Writes the resulting buffer to this Filer object.
Public method WriteScale3d Writes the specified scale value to this Filer object.
Public method WriteString Writes the specified string value to this Filer object.
Public method WriteUInt16 Writes the specified UInt16 value to this Filer object.
Public method WriteUInt32 Writes the specified UInt32 value to this Filer object.
Public method WriteUInt64 Writes the specified UInt64 value to this Filer object.
Public method WriteVector2d Writes the specified 2D vector to this Filer object.
Public method WriteVector3d Writes the specified 3D vector to this Filer object.
Public method WriteXDataStart Indicates the start of xdata in this Filer object.
Top
See Also

©  Bricsys NV. All rights reserved.