MPolygon Properties |
The MPolygon type exposes the following members.
Name | Description | |
---|---|---|
![]() |
![]() |
![]() |
Area | Property that represents the area of this entity. |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
Elevation | Property that represents the elevation of this entity in the OCS. |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
Hatch | Property that represents a hatch of the polygon. |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
Normal | Property that represents the WCS normal to the plane of this entity. |
![]() |
NumMPolygonLoops | Property that represents the number of loops in the closed polygon. |
![]() |
NumPatternDefinitions | Property that represents the number of pattern definition lines. |
![]() |
![]() |
![]() |
OffsetVector | Property that represents the offset vector. |
![]() |
![]() |
![]() |
PatternAngle | Property that represents the pattern angle in radians. |
![]() |
PatternColor | Property that represents the color information of a pattern. |
![]() |
PatternDouble | Property that represents the pattern double flag. This flag causes a second set of lines, at 90° to the first, for kUserDefined hatches. |
![]() |
PatternName | Property that represents the name of the pattern. |
![]() |
PatternScale | Property that represents the pattern scale. |
![]() |
PatternSpace | Property that represents the pattern spacing. Pattern spacing is the distance between parallel lines for kUserDefined hatches. |
![]() |
PatternType | Property that represents the hatch pattern type for this entity. |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |