BoundedPlane Class

This .NET class wraps the OdGeBoundedPlane class.
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.GeometryEntity3d
        Teigha.GeometrySurface
          Teigha.GeometryPlanarEntity
            Teigha.GeometryBoundedPlane

Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public sealed class BoundedPlane : PlanarEntity

The BoundedPlane type exposes the following members.

Constructors
  Name Description
Public method BoundedPlane Default constructor for the BoundedPlane class. Constructs an infinite plane parallel to the XY plane.
Public method BoundedPlane(Point3d, Point3d, Point3d) Constructor for the BoundedPlane class. Constructs a plane defined by its origin and U and V points.
Public method BoundedPlane(Point3d, Vector3d, Vector3d) Constructor for the BoundedPlane class. Constructs a plane defined by its origin and U and V vectors.
Top
Properties
  Name Description
Top
Methods
  Name Description
Public methodStatic member Create Creates a BoundedPlane object based on the passed pointer.
Public method IntersectWith(BoundedPlane) Creates an intersection line between this and the passed bounded plane.
Public method IntersectWith(Plane) Creates an intersection line between this and the passed bounded plane.
Public method IntersectWith(BoundedPlane, Tolerance) Creates an intersection line between this and the passed bounded plane with the specified tolerance.
Public method IntersectWith(Plane, Tolerance) Creates an intersection line between this and the passed plane with the specified tolerance.
Public method Set(Point3d, Point3d, Point3d) Sets the origin and U and V points that define the plane.
Public method Set(Point3d, Vector3d, Vector3d) Sets the origin and U and V vectors that define the plane.
Top
See Also

©  Bricsys NV. All rights reserved.