LineSegment2d Class

Inheritance Hierarchy
Namespace:  Teigha.Geometry
Assembly:  TD_Mgd (in TD_Mgd.dll) Version: 21.4.0.0
Syntax
public sealed class LineSegment2d : LinearEntity2d

The LineSegment2d type exposes the following members.

Constructors
  Name Description
Public method LineSegment2d
Initializes a new instance of the LineSegment2d class
Public method LineSegment2d(Point2d, Point2d)
Initializes a new instance of the LineSegment2d class
Public method LineSegment2d(Point2d, Vector2d)
Initializes a new instance of the LineSegment2d class
Top
Properties
  Name Description
Public property EndPoint
Public property Length
Public property MidPoint
Public property StartPoint
Top
Methods
  Name Description
Public method BaryComb
Public methodStatic member Create
Public method GetBisector
Public method GetSegmentLength(Double, Double)
Public method GetSegmentLength(Double, Double, Tolerance)
Public method Set(Point2d, Point2d)
Public method Set(Point2d, Vector2d)
Public method Set(Curve2d, Point2d, Double)
Public method Set(Curve2d, Curve2d, Double, Double)
Top
See Also

©  Bricsys NV. All rights reserved.