WorldGeometry Class

This class defines functions that allow entities to vectorize themselves. Vectorization with the methods of this class are viewport independent. For viewport specific vectorization, use subViewportDraw() instead of subWorldDraw(). A WorldGeometry object is part of the WorldDraw argument passed to the subWorldDraw() method of an entity. Model coordinates are applied to all geometry in this class except for setExtents().
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.RuntimeRXObject
        Teigha.GraphicsInterfaceGeometry
          Teigha.GraphicsInterfaceWorldGeometry

Namespace: Teigha.GraphicsInterface
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public abstract class WorldGeometry : Geometry

The WorldGeometry type exposes the following members.

Constructors
  Name Description
Protected method WorldGeometry Initializes a new instance of the WorldGeometry class
Protected method WorldGeometry(IntPtr, Boolean) Initializes a new instance of the WorldGeometry class
Top
Properties
  Name Description
Top
Methods
  Name Description
Public method SetExtents Sets the extents of the current object.
Public method StartAttributesSegment Starts a segment of attributes for a block.
Top
See Also

©  Bricsys NV. All rights reserved.