LineSegment3d Class |
The LineSegment3d type exposes the following members.
Name | Description | |
---|---|---|
![]() |
LineSegment3d |
Initializes a new instance of the LineSegment3d class
|
![]() |
LineSegment3d(Point3d, Point3d) |
Initializes a new instance of the LineSegment3d class
|
![]() |
LineSegment3d(Point3d, Vector3d) |
Initializes a new instance of the LineSegment3d class
|
Name | Description | |
---|---|---|
![]() |
AutoDelete | (Inherited from DisposableWrapper.) |
![]() |
BoundBlock | (Inherited from Curve3d.) |
![]() |
Direction | (Inherited from LinearEntity3d.) |
![]() |
EndPoint | |
![]() |
HasEndPoint | (Inherited from Curve3d.) |
![]() |
HasStartPoint | (Inherited from Curve3d.) |
![]() |
IsDisposed | (Inherited from DisposableWrapper.) |
![]() |
Length | |
![]() |
MidPoint | |
![]() |
OrthoBoundBlock | (Inherited from Curve3d.) |
![]() |
PointOnLine | (Inherited from LinearEntity3d.) |
![]() |
StartPoint | |
![]() |
UnmanagedObject | (Inherited from DisposableWrapper.) |
Name | Description | |
---|---|---|
![]() |
BaryComb | |
![]() |
Clone | (Inherited from Entity3d.) |
![]() ![]() |
Create | |
![]() |
CreateObjRef |
Creates an object that contains all the
relevant information required to generate a proxy used to
communicate with a remote object.
(Inherited from MarshalByRefObject.) |
![]() |
Dispose | (Inherited from DisposableWrapper.) |
![]() |
Equals | (Inherited from DisposableWrapper.) |
![]() |
EvaluatePoint |
Retrieves the point on the curve corresponding
to the specified parameter value.
(Inherited from Curve3d.) |
![]() |
Explode |
Explodes the curve into its component
sub-curves.
(Inherited from Curve3d.) |
![]() |
GetArea(Double, Double) |
Retrieves the area of the parametric interval
defined by the passed start and end parameters.
(Inherited from Curve3d.) |
![]() |
GetArea(Double, Double, Tolerance) |
Retrieves the area of the parametric interval
defined by the passed start and end parameters.
(Inherited from Curve3d.) |
![]() |
GetBisector | |
![]() |
GetBoundBlockOf |
Retrieves the oriented bounding box of the
specified sub-interval of this curve.
(Inherited from Curve3d.) |
![]() |
GetClosestPointTo(Curve3d) |
Retrieves the closest points between this
curve and the passed curve.
(Inherited from Curve3d.) |
![]() |
GetClosestPointTo(Point3d) |
Retrieves the closest point on this curve to
the specified point.
(Inherited from Curve3d.) |
![]() |
GetClosestPointTo(Curve3d, Tolerance) |
Retrieves the closest points between this
curve and the passed curve within a specified tolerance.
(Inherited from Curve3d.) |
![]() |
GetClosestPointTo(Point3d, Tolerance) |
Retrieves the closest point on this curve to
the specified point within a specified tolerance.
(Inherited from Curve3d.) |
![]() |
GetDistanceTo(Curve3d) |
Retrieves the distance of the closest points
between this curve and the passed curve.
(Inherited from Curve3d.) |
![]() |
GetDistanceTo(Point3d) |
Retrieves the distance of the closest point on
this curve and the specified point.
(Inherited from Curve3d.) |
![]() |
GetDistanceTo(Curve3d, Tolerance) |
Retrieves the distance of the closest points
between this curve and the passed curve within a specified
tolerance.
(Inherited from Curve3d.) |
![]() |
GetDistanceTo(Point3d, Tolerance) |
Retrieves the distance of the closest point on
this curve and the specified point within a specified
tolerance.
(Inherited from Curve3d.) |
![]() |
GetHashCode | (Inherited from DisposableWrapper.) |
![]() |
GetInterval |
Retrieves the parametric interval of this
curve.
(Inherited from Curve3d.) |
![]() |
GetLength |
Retrieves the arc length of the curve between
the two parameter values.
(Inherited from Curve3d.) |
![]() |
GetLifetimeService |
Retrieves the current lifetime service object
that controls the lifetime policy for this instance.
(Inherited from MarshalByRefObject.) |
![]() |
GetLine | (Inherited from LinearEntity3d.) |
![]() |
GetNormalPoint(Point3d) |
Retrieves the point on this curve where normal
extends through the passed point.
(Inherited from Curve3d.) |
![]() |
GetNormalPoint(Point3d, Tolerance) |
Retrieves the point on this curve where normal
extends through the passed point within the specified
tolerance.
(Inherited from Curve3d.) |
![]() |
GetOrthoBoundBlockOf |
Retrieves the bounding box of the specified
parametric range of this curve. Bounding box sides are parallel to
the coordinate axes.
(Inherited from Curve3d.) |
![]() |
GetOrthoProjectEntity(Plane) |
Retrieves the entity representing the curve's
orthogonal projection onto the projection plane.
(Inherited from Curve3d.) |
![]() |
GetOrthoProjectEntity(Plane, Tolerance) |
Retrieves the entity representing the curve's
orthogonal projection onto the projection plane.
(Inherited from Curve3d.) |
![]() |
GetParameterAtLength |
Retrieves the parameter value of the point
whose arc length distance is the input length.
(Inherited from Curve3d.) |
![]() |
GetParameterOf(Point3d) |
Retrieves the parameter value of a
point.
(Inherited from Curve3d.) |
![]() |
GetParameterOf(Point3d, Tolerance) |
Retrieves the parameter value of a point
within a specified tolerance.
(Inherited from Curve3d.) |
![]() |
GetPerpendicularPlane | (Inherited from LinearEntity3d.) |
![]() |
GetProjectedClosestPointTo(Curve3d, Vector3d) |
Retrieves the point on this curve closest to
the specified curve, and the point on the passed curve closest to
this curve, when this curve is projected in the specified
direction.
(Inherited from Curve3d.) |
![]() |
GetProjectedClosestPointTo(Point3d, Vector3d) |
Retrieves the point on this curve closest to
the specified point when projected in the specified
direction.
(Inherited from Curve3d.) |
![]() |
GetProjectedClosestPointTo(Curve3d, Vector3d, Tolerance) |
Retrieves the points on this curve closest to
the specified curve, and the point on the other curve closest to
this curve, when this curve is projected in the specified
direction.
(Inherited from Curve3d.) |
![]() |
GetProjectedClosestPointTo(Point3d, Vector3d, Tolerance) |
Retrieves the point on this curve closest to
the specified point when projected in the specified
direction.
(Inherited from Curve3d.) |
![]() |
GetProjectedEntity(Plane, Vector3d) |
Retrieves the entity representing the curve's
projection onto the projection plane.
(Inherited from Curve3d.) |
![]() |
GetProjectedEntity(Plane, Vector3d, Tolerance) |
Retrieves the entity representing the curve's
projection onto the projection plane.
(Inherited from Curve3d.) |
![]() |
GetReverseParameterCurve |
Reverses the parameter *direction* of this
*curve*.
(Inherited from Curve3d.) |
![]() |
GetSamplePoints(Int32) |
Retrieves an array of sample points along this
curve.
(Inherited from Curve3d.) |
![]() |
GetSamplePoints(Double, Double, Double) |
Retrieves specified arrays of sample points
along this curve and their parameter values.
(Inherited from Curve3d.) |
![]() |
GetSplitCurves |
Retrieves two segments of this curve split at
the specified parameter value.
(Inherited from Curve3d.) |
![]() |
GetTrimmedOffset(Double, Vector3d, OffsetCurveExtensionType) |
Receives one or more offset curves that
represent the trimmed offset of the curve.
(Inherited from Curve3d.) |
![]() |
GetTrimmedOffset(Double, Vector3d, OffsetCurveExtensionType, Tolerance) |
Receives one or more offset curves that
represent the trimmed offset of the curve.
(Inherited from Curve3d.) |
![]() |
GetType |
Gets the Type of the current instance.
(Inherited from Object.) |
![]() |
InitializeLifetimeService |
Obtains a lifetime service object to control
the lifetime policy for this instance.
(Inherited from MarshalByRefObject.) |
![]() |
IntersectWith(LinearEntity3d) | (Inherited from LinearEntity3d.) |
![]() |
IntersectWith(PlanarEntity) | (Inherited from LinearEntity3d.) |
![]() |
IntersectWith(LinearEntity3d, Tolerance) | (Inherited from LinearEntity3d.) |
![]() |
IntersectWith(PlanarEntity, Tolerance) | (Inherited from LinearEntity3d.) |
![]() |
IsClosed |
Checks whether the curve is closed.
(Inherited from Curve3d.) |
![]() |
IsClosed(Tolerance) |
Checks whether the curve is closed within a
specified tolerance.
(Inherited from Curve3d.) |
![]() |
IsColinearTo(LinearEntity3d) | (Inherited from LinearEntity3d.) |
![]() |
IsColinearTo(LinearEntity3d, Tolerance) | (Inherited from LinearEntity3d.) |
![]() |
IsCoplanarWith(Curve3d, Plane) |
Checks whether the specified curve entity is
coplanar with this curve and returns the common plane.
(Inherited from Curve3d.) |
![]() |
IsCoplanarWith(Curve3d, Plane, Tolerance) |
Checks whether the specified curve entity is
coplanar with this curve and returns the common plane.
(Inherited from Curve3d.) |
![]() |
IsDegenerate(Entity3d) |
Checks whether this curve is degenerate and
returns the type of entity that the curve degenerates to (if
degenerate).
(Inherited from Curve3d.) |
![]() |
IsDegenerate(Entity3d, Tolerance) |
Checks whether this curve is degenerate and
returns the type of entity that the curve degenerates to (if
degenerate).
(Inherited from Curve3d.) |
![]() |
IsEqualTo(Entity3d) | (Inherited from Entity3d.) |
![]() |
IsEqualTo(Entity3d, Tolerance) | (Inherited from Entity3d.) |
![]() |
IsLinear(Line3d) |
Checks whether this curve is linear.
(Inherited from Curve3d.) |
![]() |
IsLinear(Line3d, Tolerance) |
Checks whether this curve is linear within a
specified tolerance.
(Inherited from Curve3d.) |
![]() |
IsOn(Double) |
Checks whether a specified parameter value is
within a valid parametric range of the curve.
(Inherited from Curve3d.) |
![]() |
IsOn(Plane) | (Inherited from LinearEntity3d.) |
![]() |
IsOn(Point3d) |
Checks whether a specified point lies on this
curve.
(Inherited from Curve3d.) |
![]() |
IsOn(Double, Tolerance) |
Checks whether a specified parameter value is
within a valid parametric range of the curve.
(Inherited from Curve3d.) |
![]() |
IsOn(Plane, Tolerance) | (Inherited from LinearEntity3d.) |
![]() |
IsOn(Point3d, Double) |
Checks whether a specified point lies on this
curve.
(Inherited from Curve3d.) |
![]() |
IsOn(Point3d, Tolerance) |
Checks whether a specified point lies on this
curve within a specified tolerance.
(Inherited from Curve3d.) |
![]() |
IsOn(Point3d, Double, Tolerance) |
Checks whether a specified point lies on this
curve.
(Inherited from Curve3d.) |
![]() |
IsParallelTo(LinearEntity3d) | (Inherited from LinearEntity3d.) |
![]() |
IsParallelTo(PlanarEntity) | (Inherited from LinearEntity3d.) |
![]() |
IsParallelTo(LinearEntity3d, Tolerance) | (Inherited from LinearEntity3d.) |
![]() |
IsParallelTo(PlanarEntity, Tolerance) | (Inherited from LinearEntity3d.) |
![]() |
IsPeriodic |
Checks whether the curve is periodic.
(Inherited from Curve3d.) |
![]() |
IsPerpendicularTo(LinearEntity3d) | (Inherited from LinearEntity3d.) |
![]() |
IsPerpendicularTo(PlanarEntity) | (Inherited from LinearEntity3d.) |
![]() |
IsPerpendicularTo(LinearEntity3d, Tolerance) | (Inherited from LinearEntity3d.) |
![]() |
IsPerpendicularTo(PlanarEntity, Tolerance) | (Inherited from LinearEntity3d.) |
![]() |
IsPlanar(Plane) |
Checks whether this curve is planar. If the
curve is a line, this function returns an arbitrary plane that
contains the line. The plane parameter contains meaningful data
only if this function returns a value of true.
(Inherited from Curve3d.) |
![]() |
IsPlanar(Plane, Tolerance) |
Checks whether this curve is planar within a
specified tolerance. If the curve is a line, this function returns
an arbitrary plane that contains the line. The plane parameter
contains meaningful data only if this function returns a value of
true.
(Inherited from Curve3d.) |
![]() |
Mirror | (Inherited from Entity3d.) |
![]() |
Overlap(LinearEntity3d) | (Inherited from LinearEntity3d.) |
![]() |
Overlap(LinearEntity3d, Tolerance) | (Inherited from LinearEntity3d.) |
![]() |
ProjectedIntersectWith(LinearEntity3d, Vector3d) | (Inherited from LinearEntity3d.) |
![]() |
ProjectedIntersectWith(LinearEntity3d, Vector3d, Tolerance) | (Inherited from LinearEntity3d.) |
![]() |
RotateBy | (Inherited from Entity3d.) |
![]() |
ScaleBy | (Inherited from Entity3d.) |
![]() |
Set(Point3d, Point3d) | |
![]() |
Set(Point3d, Vector3d) | |
![]() |
Set(Curve3d, Point3d, Double) | |
![]() |
Set(Curve3d, Curve3d, Double, Double) | |
![]() |
SetInterval |
Sets the parametric range of this curve.
(Inherited from Curve3d.) |
![]() |
ToString |
Returns a string that represents the current
object.
(Inherited from Object.) |
![]() |
TransformBy | (Inherited from Entity3d.) |
![]() |
TranslateBy | (Inherited from Entity3d.) |
© Bricsys NV. All rights reserved. |