MlineStyle Class

This class represents multiline style objects in a database.
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.RuntimeRXObject
        Teigha.GraphicsInterfaceDrawable
          Teigha.DatabaseServicesDBObject
            Teigha.DatabaseServicesMlineStyle

Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public class MlineStyle : DBObject

The MlineStyle type exposes the following members.

Constructors
  Name Description
Public method MlineStyle Default constructor for the MlineStyle class.
Protected method MlineStyle(IntPtr, Boolean) Initializes a new instance of the MlineStyle class
Top
Properties
  Name Description
Public property Description Property that represents the description for this MlineStyle object.
Public property Elements Property that represents elements of this MlineStyle object. The elements contain information about the color, offset, and linetype ID values used in a multiline style.
Public property EndAngle Property that represents the end angle for this MlineStyle object.
Public property EndInnerArcs Property that indicates whether end inner arcs are displayed.
Public property EndRoundCap Property that indicates whether end round caps are displayed.
Public property EndSquareCap Property that indicates whether end square caps are displayed.
Public property FillColor Property that represents the fill color for this MlineStyle object.
Public property Filled Property that indicates whether multiline objects using this style are filled.
Public property Name Property that represents the name of this style.
Public property ShowMiters Property that indicates whether miters are displayed.
Public property StartAngle Property that represents the start angle for this MlineStyle object.
Public property StartInnerArcs Property that indicates whether start inner arcs are displayed.
Public property StartRoundCap Property that indicates whether start round caps are displayed.
Public property StartSquareCap Property that indicates whether start square caps are displayed.
Top
Methods
  Name Description
Public method Reset Re-initializes this MlineStyle object. Properties after the re-initialization: PropertyValueName Empty string Description Empty string FillColor 0 StartAngle 90° EndAngle 90° ElementList Empty
Public method Set Copies the specified MlineStyle object to this MlineStyle object.
Top
Events
  Name Description
Top
See Also

©  Bricsys NV. All rights reserved.