Raster
|
The RasterImageDef type exposes the following members.
Name | Description | |
---|---|---|
![]() |
RasterImageDef | Default constructor for the RasterImageDef class. |
![]() |
RasterImageDef(IntPtr, Boolean) | Initializes a new instance of the RasterImageDef class |
Name | Description | |
---|---|---|
![]() |
AcadObject | (Inherited from DBObject) |
![]() |
ActiveFileName | Property that represents the path name of the actual file that is currently used to define the image. |
![]() |
Annotative | (Inherited from DBObject) |
![]() |
AutoDelete | (Inherited from DisposableWrapper) |
![]() |
Bounds | (Inherited from Drawable) |
![]() |
ClassID | (Inherited from DBObject) |
![]() |
ColorDepth | Property that represents the color depth of the image (bits per pixel). Available values: 1, 8, 24, or 32. |
![]() |
Database | (Inherited from DBObject) |
![]() |
Drawable | Property that represents a drawable that is associated with
this object. (Inherited from DBObject) |
![]() |
DrawableType | (Inherited from Drawable) |
![]() |
ExtensionDictionary | (Inherited from DBObject) |
![]() |
FileDescCopy | Property that represents an additional file description containing information such as file type, resolution, etc. |
![]() |
FileType | Property that represents the type of image file. |
![]() |
Handle | (Inherited from DBObject) |
![]() |
HasFields | (Inherited from DBObject) |
![]() |
HasSaveVersionOverride | (Inherited from DBObject) |
![]() |
Id | Property that represents an object identifier of this database
object. (Inherited from DBObject) |
![]() |
ImageModified | Property that indicates whether the image is modified. |
![]() |
IsAProxy | (Inherited from DBObject) |
![]() |
IsCancelling | (Inherited from DBObject) |
![]() |
IsDisposed | (Inherited from DisposableWrapper) |
![]() |
IsEmbedded | Property that indicates whether the image is embedded in the drawing file. |
![]() |
IsErased | (Inherited from DBObject) |
![]() |
IsEraseStatusToggled | (Inherited from DBObject) |
![]() |
IsLoaded | Property that indicates whether the image is loaded. |
![]() |
IsModified | (Inherited from DBObject) |
![]() |
IsModifiedGraphics | (Inherited from DBObject) |
![]() |
IsModifiedXData | (Inherited from DBObject) |
![]() |
IsNewObject | (Inherited from DBObject) |
![]() |
IsNotifyEnabled | (Inherited from DBObject) |
![]() |
IsNotifying | (Inherited from DBObject) |
![]() |
IsObjectIdsInFlux | (Inherited from DBObject) |
![]() |
IsPersistent | Property that indicates whether this object is a
database-resident (DBRO). Persistent objects belong to an object
that must be opened and closed. Non-persistent objects can be
accessed through their pointers. (Inherited from DBObject) |
![]() |
IsReadEnabled | (Inherited from DBObject) |
![]() |
IsReallyClosing | (Inherited from DBObject) |
![]() |
IsTransactionResident | (Inherited from DBObject) |
![]() |
IsUndoing | (Inherited from DBObject) |
![]() |
IsWriteEnabled | (Inherited from DBObject) |
![]() |
MergeStyle | (Inherited from DBObject) |
![]() |
ObjectBirthVersion | (Inherited from DBObject) |
![]() |
ObjectId | (Inherited from DBObject) |
![]() |
Organization | Property that represents the pixel organization scheme of the source image file. |
![]() |
OwnerId | (Inherited from DBObject) |
![]() |
PaperOrientation | (Inherited from DBObject) |
![]() |
ResolutionMMPerPixel | Property that represents the default physical pixel size, in mm/pixel, of the image for this raster image definition object. |
![]() |
ResolutionUnits | Property that represents the resolution units of the image for this raster image definition object. |
![]() |
SearchForActivePath | Obsolete. Property that represents the path name of the actual file that is currently used to define the image. |
![]() |
Size | Property that represents the image size in pixels. |
![]() |
SourceFileName | Property that represents the name of the source file containing the raster image for this raster image definition object. |
![]() |
UndoFiler | (Inherited from DBObject) |
![]() |
UndoStoreSize | Property that represents the current value of the Undo store size. |
![]() |
UnmanagedObject | (Inherited from DisposableWrapper) |
![]() |
XData | (Inherited from DBObject) |
Name | Description | |
---|---|---|
![]() |
AddContext | Adds a copy of a context to the object. (Inherited from DBObject) |
![]() |
AddPersistentReactor | Adds the specified persistent reactor to this object's reactor
list. (Inherited from DBObject) |
![]() |
ApplyPartialUndo | Notification method that is called each time this object uses
the partial undo mechanism. (Inherited from DBObject) |
![]() |
AssertNotifyEnabled | (Inherited from DBObject) |
![]() |
AssertReadEnabled | (Inherited from DBObject) |
![]() |
AssertWriteEnabled | (Inherited from DBObject) |
![]() |
Audit | Performs an audit operation on this object. (Inherited from DBObject) |
![]() |
Cancel | Obsolete. Terminates the current open operation. Currently not implemented. (Inherited from DBObject) |
![]() |
Clone | (Inherited from RXObject) |
![]() |
Close | Obsolete. Closes the object. All changes made to the object since it was opened are committed to the database and a notification is sent that the object is now "closed". Currently not implemented. (Inherited from DBObject) |
![]() |
CloseAndPage | Obsolete. Closes the object and pages it if the object pager is enabled. All changes made to the object since it was opened are committed to the database and a notification is sent that the object is now "closed". Currently not implemented. (Inherited from DBObject) |
![]() |
CloseImage | Closes the associated image data object. |
![]() |
CompareTo | (Inherited from RXObject) |
![]() |
CopyFrom | (Inherited from RXObject) |
![]() |
CreateExtensionDictionary | Creates a DbDictionary extension dictionary of this
object. (Inherited from DBObject) |
![]() ![]() |
CreateImageDictionary | Creates a new image dictionary. |
![]() |
CreateObjRef | Creates an object that contains all the relevant information
required to generate a proxy used to communicate with a remote
object. (Inherited from MarshalByRefObject) |
![]() |
DecomposeForSave | Determines the behavior for custom objects when saving to a
.dwg file. (Inherited from DBObject) |
![]() |
DeepClone | Performs a deep clone of this object. (Inherited from DBObject) |
![]() |
DeleteUnmanagedObject | (Inherited from DBObject) |
![]() |
DisableUndoRecording | Controls the undo recording of this object in
OdDbDatabase. (Inherited from DBObject) |
![]() |
Dispose | (Inherited from DisposableWrapper) |
![]() |
Dispose(Boolean) | (Inherited from DBObject) |
![]() |
DowngradeOpen | Downgrades this object from ForWrite
to ForRead. (Inherited from DBObject) |
![]() |
DowngradeToNotify | Downgrades this object from ForNotify
and ForWrite to having just one open mode
- ForNotify. Currently not
implemented. (Inherited from DBObject) |
![]() |
DwgIn | Reads the .dwg file format data of this object from the
specified file. (Inherited from DBObject) |
![]() |
DwgInFields | (Inherited from DBObject) |
![]() |
DwgOut | Writes the .dwg file format data of this object to the
specified filer. (Inherited from DBObject) |
![]() |
DwgOutFields | (Inherited from DBObject) |
![]() |
DxfIn | Reads the .dxf file format data of this object from the
specified file. (Inherited from DBObject) |
![]() |
DxfInFields | (Inherited from DBObject) |
![]() |
DxfOut | Writes the .dxf file format data of this object to the
specified filer. (Inherited from DBObject) |
![]() |
DxfOutFields | (Inherited from DBObject) |
![]() |
Embed | Embeds the associated image data. |
![]() |
Equals | (Inherited from DisposableWrapper) |
![]() |
Erase | Marks this object as "erased". (Inherited from DBObject) |
![]() |
Erase(Boolean) | Sets the erased mode of this object. (Inherited from DBObject) |
![]() |
Finalize | (Inherited from DisposableWrapper) |
![]() |
GetEntityCount | Returns the number of raster images associated with this raster image definition object. |
![]() |
GetEventExtender | (Inherited from DBObject) |
![]() |
GetField | Returns the object ID of a "TEXT" field object from the field
dictionary. (Inherited from DBObject) |
![]() |
GetField(String) | Returns the object ID of the specified field object (that
matches the property name) from the field dictionary. (Inherited from DBObject) |
![]() |
GetHashCode | (Inherited from DisposableWrapper) |
![]() ![]() |
GetImageDictionary | Returns the image dictionary in the specified database. |
![]() |
GetLifetimeService | Retrieves the current lifetime service object that controls the
lifetime policy for this instance. (Inherited from MarshalByRefObject) |
![]() |
GetObjectSaveVersion(DwgFiler) | Returns the drawing and maintenance release version into which
this object must be stored. (Inherited from DBObject) |
![]() |
GetObjectSaveVersion(DxfFiler) | Returns the drawing and maintenance release version into which
this object must be stored. (Inherited from DBObject) |
![]() |
GetPersistentReactorIds | Returns the object IDs of this object's persistent
reactors. (Inherited from DBObject) |
![]() |
GetReactors | Obsolete. Returns this object's transient reactors. (Inherited from DBObject) |
![]() |
GetRXClass | (Inherited from RXObject) |
![]() |
GetTransientReactors | Returns this object's transient reactors. (Inherited from DBObject) |
![]() |
GetType | Gets the Type of the current
instance. (Inherited from Object) |
![]() |
GetXDataForApplication | Returns a linked list of ResBufs containing a copy of the XData
of this object. (Inherited from DBObject) |
![]() |
HandOverTo | Replaces this database-resident (DBRO) object with the
specified non-database-resident (NDBRO) object, while retaining
this object's objectId, handle, owner, and reactor list. (Inherited from DBObject) |
![]() |
HasContext | Checks whether the specified context exists in the
collection. (Inherited from DBObject) |
![]() |
HasPersistentReactor | Checks whether the passed identifier is an identifier of a
reactor attached to this object. (Inherited from DBObject) |
![]() |
ImageCopy | Creates a copy of the image data. |
![]() |
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime
policy for this instance. (Inherited from MarshalByRefObject) |
![]() |
Load | Loads the source image file for this raster image definition object. |
![]() |
LocateActivePath | Returns the path name of the actual file that is currently used to define the image. |
![]() |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object) |
![]() |
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject
object. (Inherited from MarshalByRefObject) |
![]() |
OpenImage | Opens the associated image data object for write operations. |
![]() |
QueryX | (Inherited from RXObject) |
![]() |
RegenSupportFlags | (Inherited from Drawable) |
![]() |
ReleaseExtensionDictionary | Releases and erases this object's extension dictionary if it
exists and is empty. (Inherited from DBObject) |
![]() |
RemoveContext | Removes a context from the collection. An active context can't
be removed. (Inherited from DBObject) |
![]() |
RemoveField | Removes the text field and returns its field ID. (Inherited from DBObject) |
![]() |
RemoveField(ObjectId) | Removes the specified field. (Inherited from DBObject) |
![]() |
RemoveField(String) | Removes the specified field by its name and returns its
ID. (Inherited from DBObject) |
![]() |
RemovePersistentReactor | Removes the specified persistent reactor from this object's
reactor list. (Inherited from DBObject) |
![]() |
ResetScaleDependentProperties | Resets object properties that depend on scale to the default
values. (Inherited from DBObject) |
![]() |
SetAttributes | Sets the vectorization attributes of this object, and returns
its attribute flags. (Inherited from Drawable) |
![]() |
SetField(Field) | Sets the specified field for the "TEXT" property. (Inherited from DBObject) |
![]() |
SetField(String, Field) | Sets the specified field for the specified property. (Inherited from DBObject) |
![]() |
SetFromStyle | Sets the annotative property of an object according to its
corresponding style, such as styles of text objects. (Inherited from DBObject) |
![]() |
SetImage | Creates an image from the specified pointer. |
![]() |
SetObjectIdsInFlux | Called on a newly created cloned object to indicate that its
object ID is not valid. (Inherited from DBObject) |
![]() |
SetPaperOrientation | Sets the paper orientation property of a specified
object. (Inherited from DBObject) |
![]() |
SubRegenSupportFlags | (Inherited from Drawable) |
![]() |
SubSetAttributes | (Inherited from DBObject) |
![]() |
SubViewportDraw | (Inherited from DBObject) |
![]() |
SubViewportDrawLogicalFlags | (Inherited from DBObject) |
![]() |
SubWorldDraw | (Inherited from DBObject) |
![]() ![]() |
SuggestName | Modifies the original image filename. |
![]() |
SupportsCollection | Checks whether a particular context type is supported by this
object. This method shows whether an object supports a collection
type but does not show whether this object participates in any
contexts of that type. (Inherited from DBObject) |
![]() |
SwapIdWith | Swaps the objectIDs, handles, extended data (XData), and
extension dictionary between this object and another object. (Inherited from DBObject) |
![]() |
SwapReferences | This method performs object ID reference translations similar
to those done at the end of deep cloning. References between
objects in the workset have their object identifiers translated to
the swapped object identifiers of the referenced objects. In
contrast to cloning, this translation must occur in both
directions. Accordingly, it is possible to pass two different ID
maps in two different calls to this method. Currently not
implemented. (Inherited from DBObject) |
![]() |
ToString | Returns a string that represents the current object. (Inherited from Object) |
![]() |
Unload | Unloads the image for this raster image definition object. |
![]() |
UpdateEntities | Causes all raster images associated with this raster image definition object to be redrawn. |
![]() |
UpgradeFromNotify | Upgrades the object from at least ForNotify mode to both ForNotify and ForWrite
modes. You should place a call to DowngradeToNotify() with no Open() or Close() methods
in between. For internal use. Currently not implemented. (Inherited from DBObject) |
![]() |
UpgradeOpen | (Inherited from DBObject) |
![]() |
ViewportDraw | Creates a viewport-dependent geometric representation of this
object. (Inherited from Drawable) |
![]() |
ViewportDrawLogicalFlags | Retrieves the setAttributes flags for the current
viewportDraw. (Inherited from Drawable) |
![]() |
WblockClone | Performs a shallow clone of this object. (Inherited from DBObject) |
![]() |
WorldDraw | Creates a viewport-independent geometric representation of this
object. (Inherited from Drawable) |
![]() |
X | (Inherited from RXObject) |
![]() |
XDataTransformBy | Applies the 3D transformation matrix to the XData of this
object. (Inherited from DBObject) |
Name | Description | |
---|---|---|
![]() |
Cancelled | (Inherited from DBObject) |
![]() |
Copied | Notification event called whenever the notifying object has had
its clone() member function called. (Inherited from DBObject) |
![]() |
Erased | Notification event called whenever an object has been erased or
unerased. (Inherited from DBObject) |
![]() |
Goodbye | Notification event called just before an object is deleted from
memory. (Inherited from DBObject) |
![]() |
Modified | Notification event called whenever an object is opened
ForWrite, a function has been called that
could modify the content of this object, and this object is now
being closed. (Inherited from DBObject) |
![]() |
ModifiedXData | Notification event called whenever the XData has been written
to the notifying object. (Inherited from DBObject) |
![]() |
ModifyUndone | Notification event called whenever the notifying object is
currently performing an undo operation that is undoing
modifications. (Inherited from DBObject) |
![]() |
ObjectClosed | Notification event called immediately before an object is
closed. (Inherited from DBObject) |
![]() |
OpenedForModify | Notification event called whenever an object is opened for
modifying ForWrite. (Inherited from DBObject) |
![]() |
Reappended | Notification event called whenever a redo process processes the
reappending of the notifying object to the database. (Inherited from DBObject) |
![]() |
SubObjectModified | (Inherited from DBObject) |
![]() |
Unappended | Notification event called whenever the undo process processes
the appending of the notifying object to the database. (Inherited from DBObject) |
© Bricsys NV. All rights reserved. |