IAcadTable Interface


Namespace: BricscadDb
Assembly: Interop.BricscadDb (in Interop.BricscadDb.dll) Version: 24.0.0.0
Syntax
public interface IAcadTable : IAcadEntity

The IAcadTable type exposes the following members.

Properties
Methods
  Name Description
Public method ArrayPolar  
Public method ArrayRectangular  
Public method ClearSubSelection  
Public method ClearTableStyleOverrides  
Public method Copy  
Public method CreateContent  
Public method Delete  
Public method DeleteCellContent  
Public method DeleteColumns  
Public method DeleteContent  
Public method DeleteRows  
Public method EnableMergeAll  
Public method Erase  
Public method FormatValue  
Public method GenerateLayout  
Public method GetAlignment  
Public method GetAttachmentPoint  
Public method GetAutoScale  
Public method GetAutoScale2  
Public method GetBackgroundColor  
Public method GetBackgroundColorNone  
Public method GetBlockAttributeValue  
Public method GetBlockAttributeValue2  
Public method GetBlockAttributeValue232  
Public method GetBlockAttributeValue32  
Public method GetBlockRotation  
Public method GetBlockScale  
Public method GetBlockTableRecordId  
Public method GetBlockTableRecordId2  
Public method GetBlockTableRecordId232  
Public method GetBlockTableRecordId32  
Public method GetBoundingBox  
Public method GetBreakHeight  
Public method GetCellAlignment  
Public method GetCellBackgroundColor  
Public method GetCellBackgroundColorNone  
Public method GetCellContentColor  
Public method GetCellDataType  
Public method GetCellExtents  
Public method GetCellFormat  
Public method GetCellGridColor  
Public method GetCellGridLineWeight  
Public method GetCellGridVisibility  
Public method GetCellState  
Public method GetCellStyle  
Public method GetCellStyleOverrides  
Public method GetCellTextHeight  
Public method GetCellTextStyle  
Public method GetCellType  
Public method GetCellValue  
Public method GetColumnName  
Public method GetColumnWidth  
Public method GetContentColor  
Public method GetContentColor2  
Public method GetContentLayout  
Public method GetContentType  
Public method GetCustomData  
Public method GetDataFormat  
Public method GetDataType  
Public method GetDataType2  
Public method GetExtensionDictionary  
Public method GetFieldId  
Public method GetFieldId2  
Public method GetFieldId232  
Public method GetFieldId32  
Public method GetFormat  
Public method GetFormula  
Public method GetGridColor  
Public method GetGridColor2  
Public method GetGridDoubleLineSpacing  
Public method GetGridLineStyle  
Public method GetGridLinetype  
Public method GetGridLinetype32  
Public method GetGridLineWeight  
Public method GetGridLineWeight2  
Public method GetGridVisibility  
Public method GetGridVisibility2  
Public method GetHasFormula  
Public method GetMargin  
Public method GetMinimumColumnWidth  
Public method GetMinimumRowHeight  
Public method GetOverride  
Public method GetRotation  
Public method GetRowHeight  
Public method GetRowType  
Public method GetScale  
Public method GetSubSelection  
Public method GetText  
Public method GetTextHeight  
Public method GetTextHeight2  
Public method GetTextRotation  
Public method GetTextString  
Public method GetTextStyle  
Public method GetTextStyle2  
Public method GetValue  
Public method GetXData  
Public method Highlight  
Public method HitTest  
Public method InsertColumns  
Public method InsertColumnsAndInherit  
Public method InsertRows  
Public method InsertRowsAndInherit  
Public method IntersectWith  
Public method IsContentEditable  
Public method IsEmpty  
Public method IsFormatEditable  
Public method IsMergeAllEnabled  
Public method IsMergedCell  
Public method MergeCells  
Public method Mirror  
Public method Mirror3D  
Public method Move  
Public method MoveContent  
Public method RecomputeTableBlock  
Public method RemoveAllOverrides  
Public method ReselectSubRegion  
Public method ResetCellValue  
Public method Rotate  
Public method Rotate3D  
Public method ScaleEntity  
Public method Select  
Public method SelectSubRegion  
Public method SetAlignment  
Public method SetAutoScale  
Public method SetAutoScale2  
Public method SetBackgroundColor  
Public method SetBackgroundColorNone  
Public method SetBlockAttributeValue  
Public method SetBlockAttributeValue2  
Public method SetBlockAttributeValue232  
Public method SetBlockAttributeValue32  
Public method SetBlockRotation  
Public method SetBlockScale  
Public method SetBlockTableRecordId  
Public method SetBlockTableRecordId2  
Public method SetBlockTableRecordId232  
Public method SetBlockTableRecordId32  
Public method SetBreakHeight  
Public method SetCellAlignment  
Public method SetCellBackgroundColor  
Public method SetCellBackgroundColorNone  
Public method SetCellContentColor  
Public method SetCellDataType  
Public method SetCellFormat  
Public method SetCellGridColor  
Public method SetCellGridLineWeight  
Public method SetCellGridVisibility  
Public method SetCellState  
Public method SetCellStyle  
Public method SetCellTextHeight  
Public method SetCellTextStyle  
Public method SetCellType  
Public method SetCellValue  
Public method SetCellValueFromText  
Public method SetColumnName  
Public method SetColumnWidth  
Public method SetContentColor  
Public method SetContentColor2  
Public method SetContentLayout  
Public method SetCustomData  
Public method SetDataFormat  
Public method SetDataType  
Public method SetDataType2  
Public method SetFieldId  
Public method SetFieldId2  
Public method SetFieldId232  
Public method SetFieldId32  
Public method SetFormat  
Public method SetFormula  
Public method SetGridColor  
Public method SetGridColor2  
Public method SetGridDoubleLineSpacing  
Public method SetGridLineStyle  
Public method SetGridLinetype  
Public method SetGridLinetype32  
Public method SetGridLineWeight  
Public method SetGridLineWeight2  
Public method SetGridVisibility  
Public method SetGridVisibility2  
Public method SetMargin  
Public method SetOverride  
Public method SetRotation  
Public method SetRowHeight  
Public method SetScale  
Public method SetSubSelection  
Public method SetText  
Public method SetTextHeight  
Public method SetTextHeight2  
Public method SetTextRotation  
Public method SetTextString  
Public method SetTextStyle  
Public method SetTextStyle2  
Public method SetToolTip  
Public method SetValue  
Public method SetValueFromText  
Public method SetXData  
Public method TransformBy  
Public method UnmergeCells  
Public method Update  
Top
See Also

©  Bricsys NV. All rights reserved.