View
|
The ViewTableRecord type exposes the following members.
Name | Description | |
---|---|---|
![]() |
ViewTableRecord | Default constructor for the ViewTableRecord class. |
![]() |
ViewTableRecord(IntPtr, Boolean) | Initializes a new instance of the ViewTableRecord class |
Name | Description | |
---|---|---|
![]() |
AcadObject | (Inherited from DBObject) |
![]() |
AmbientLightColor | (Inherited from AbstractViewTableRecord) |
![]() |
AnnotationScale | Property that represents the annotation scale object associated with the viewport. |
![]() |
Annotative | (Inherited from DBObject) |
![]() |
AutoDelete | (Inherited from DisposableWrapper) |
![]() |
BackClipDistance | (Inherited from AbstractViewTableRecord) |
![]() |
BackClipEnabled | (Inherited from AbstractViewTableRecord) |
![]() |
Background | (Inherited from AbstractViewTableRecord) |
![]() |
Bounds | (Inherited from Drawable) |
![]() |
Brightness | (Inherited from AbstractViewTableRecord) |
![]() |
CategoryName | Property that represents the name of the category of the view. |
![]() |
CenterPoint | (Inherited from AbstractViewTableRecord) |
![]() |
ClassID | (Inherited from DBObject) |
![]() |
Contrast | (Inherited from AbstractViewTableRecord) |
![]() |
Database | (Inherited from DBObject) |
![]() |
DefaultLightingOn | (Inherited from AbstractViewTableRecord) |
![]() |
DefaultLightingType | (Inherited from AbstractViewTableRecord) |
![]() |
Drawable | Property that represents a drawable that is associated with
this object. (Inherited from DBObject) |
![]() |
DrawableType | (Inherited from Drawable) |
![]() |
Elevation | (Inherited from AbstractViewTableRecord) |
![]() |
ExtensionDictionary | (Inherited from DBObject) |
![]() |
FrontClipAtEye | (Inherited from AbstractViewTableRecord) |
![]() |
FrontClipDistance | (Inherited from AbstractViewTableRecord) |
![]() |
FrontClipEnabled | (Inherited from AbstractViewTableRecord) |
![]() |
Handle | (Inherited from DBObject) |
![]() |
HasFields | (Inherited from DBObject) |
![]() |
HasSaveVersionOverride | (Inherited from DBObject) |
![]() |
Height | (Inherited from AbstractViewTableRecord) |
![]() |
Id | Property that represents an object identifier of this database
object. (Inherited from DBObject) |
![]() |
IsAProxy | (Inherited from DBObject) |
![]() |
IsCancelling | (Inherited from DBObject) |
![]() |
IsDependent | Property that indicates whether this record is
XREF-dependent. (Inherited from SymbolTableRecord) |
![]() |
IsDisposed | (Inherited from DisposableWrapper) |
![]() |
IsErased | (Inherited from DBObject) |
![]() |
IsEraseStatusToggled | (Inherited from DBObject) |
![]() |
IsModified | (Inherited from DBObject) |
![]() |
IsModifiedGraphics | (Inherited from DBObject) |
![]() |
IsModifiedXData | (Inherited from DBObject) |
![]() |
IsNewObject | (Inherited from DBObject) |
![]() |
IsNotifyEnabled | (Inherited from DBObject) |
![]() |
IsNotifying | (Inherited from DBObject) |
![]() |
IsObjectIdsInFlux | (Inherited from DBObject) |
![]() |
IsPaperspaceView | Property that indicates whether the associated view is a paper space view. |
![]() |
IsPersistent | Property that indicates whether this object is a
database-resident (DBRO). Persistent objects belong to an object
that must be opened and closed. Non-persistent objects can be
accessed through their pointers. (Inherited from DBObject) |
![]() |
IsReadEnabled | (Inherited from DBObject) |
![]() |
IsReallyClosing | (Inherited from DBObject) |
![]() |
IsResolved | Property that indicates whether this record is XREF-dependent
and resolved. (Inherited from SymbolTableRecord) |
![]() |
IsTransactionResident | (Inherited from DBObject) |
![]() |
IsUcsAssociatedToView | Property that indicates whether there is a UCS associated with the view. |
![]() |
IsUndoing | (Inherited from DBObject) |
![]() |
IsWriteEnabled | (Inherited from DBObject) |
![]() |
LayerState | Property that represents the name of the layer state of the associated view. |
![]() |
Layout | Property that represents the object ID of the Layout object of the associated view. |
![]() |
LensLength | (Inherited from AbstractViewTableRecord) |
![]() |
LiveSection | Property that represents the object ID of the live section associated with a view. When a view is restored, its associated live section is enabled. |
![]() |
MergeStyle | (Inherited from DBObject) |
![]() |
Name | (Inherited from SymbolTableRecord) |
![]() |
ObjectBirthVersion | (Inherited from DBObject) |
![]() |
ObjectId | (Inherited from DBObject) |
![]() |
OwnerId | (Inherited from DBObject) |
![]() |
PaperOrientation | (Inherited from DBObject) |
![]() |
PerspectiveEnabled | (Inherited from AbstractViewTableRecord) |
![]() |
RenderMode | (Inherited from AbstractViewTableRecord) |
![]() |
SunId | (Inherited from AbstractViewTableRecord) |
![]() |
Target | (Inherited from AbstractViewTableRecord) |
![]() |
Thumbnail | Property that represents the preview image of the associated viewport. |
![]() |
Ucs | (Inherited from AbstractViewTableRecord) |
![]() |
UcsName | (Inherited from AbstractViewTableRecord) |
![]() |
UcsOrthographic | (Inherited from AbstractViewTableRecord) |
![]() |
UndoFiler | (Inherited from DBObject) |
![]() |
UnmanagedObject | (Inherited from DisposableWrapper) |
![]() |
ViewAssociatedToViewport | Property that indicates whether the view is associated with a paper space viewport. |
![]() |
ViewDirection | (Inherited from AbstractViewTableRecord) |
![]() |
ViewOrthographic | (Inherited from AbstractViewTableRecord) |
![]() |
ViewTwist | (Inherited from AbstractViewTableRecord) |
![]() |
VisualStyleId | (Inherited from AbstractViewTableRecord) |
![]() |
Width | (Inherited from AbstractViewTableRecord) |
![]() |
XData | (Inherited from DBObject) |
Name | Description | |
---|---|---|
![]() |
AddContext | Adds a copy of a context to the object. (Inherited from DBObject) |
![]() |
AddPersistentReactor | Adds the specified persistent reactor to this object's reactor
list. (Inherited from DBObject) |
![]() |
ApplyPartialUndo | Notification method that is called each time this object uses
the partial undo mechanism. (Inherited from DBObject) |
![]() |
AssertNotifyEnabled | (Inherited from DBObject) |
![]() |
AssertReadEnabled | (Inherited from DBObject) |
![]() |
AssertWriteEnabled | (Inherited from DBObject) |
![]() |
Audit | Performs an audit operation on this object. (Inherited from DBObject) |
![]() |
Cancel | Obsolete. Terminates the current open operation. Currently not implemented. (Inherited from DBObject) |
![]() |
Clone | (Inherited from RXObject) |
![]() |
Close | Obsolete. Closes the object. All changes made to the object since it was opened are committed to the database and a notification is sent that the object is now "closed". Currently not implemented. (Inherited from DBObject) |
![]() |
CloseAndPage | Obsolete. Closes the object and pages it if the object pager is enabled. All changes made to the object since it was opened are committed to the database and a notification is sent that the object is now "closed". Currently not implemented. (Inherited from DBObject) |
![]() |
CompareTo | (Inherited from RXObject) |
![]() |
CopyFrom | (Inherited from RXObject) |
![]() |
CreateExtensionDictionary | Creates a DbDictionary extension dictionary of this
object. (Inherited from DBObject) |
![]() |
CreateObjRef | Creates an object that contains all the relevant information
required to generate a proxy used to communicate with a remote
object. (Inherited from MarshalByRefObject) |
![]() |
DecomposeForSave | Determines the behavior for custom objects when saving to a
.dwg file. (Inherited from DBObject) |
![]() |
DeepClone | Performs a deep clone of this object. (Inherited from DBObject) |
![]() |
DeleteUnmanagedObject | (Inherited from DBObject) |
![]() |
DisableUndoRecording | Controls the undo recording of this object in
OdDbDatabase. (Inherited from DBObject) |
![]() |
DisassociateUcsFromView | Disassociates any UCS associated with this view record. |
![]() |
Dispose | (Inherited from DisposableWrapper) |
![]() |
Dispose(Boolean) | (Inherited from DBObject) |
![]() |
DowngradeOpen | Downgrades this object from ForWrite
to ForRead. (Inherited from DBObject) |
![]() |
DowngradeToNotify | Downgrades this object from ForNotify
and ForWrite to having just one open mode
- ForNotify. Currently not
implemented. (Inherited from DBObject) |
![]() |
DwgIn | Reads the .dwg file format data of this object from the
specified file. (Inherited from DBObject) |
![]() |
DwgInFields | (Inherited from DBObject) |
![]() |
DwgOut | Writes the .dwg file format data of this object to the
specified filer. (Inherited from DBObject) |
![]() |
DwgOutFields | (Inherited from DBObject) |
![]() |
DxfIn | Reads the .dxf file format data of this object from the
specified file. (Inherited from DBObject) |
![]() |
DxfInFields | (Inherited from DBObject) |
![]() |
DxfOut | Writes the .dxf file format data of this object to the
specified filer. (Inherited from DBObject) |
![]() |
DxfOutFields | (Inherited from DBObject) |
![]() |
Equals | (Inherited from DisposableWrapper) |
![]() |
Erase | Marks this object as "erased". (Inherited from DBObject) |
![]() |
Erase(Boolean) | Sets the erased mode of this object. (Inherited from DBObject) |
![]() |
Finalize | (Inherited from DisposableWrapper) |
![]() |
GetEventExtender | (Inherited from DBObject) |
![]() |
GetField | Returns the object ID of a "TEXT" field object from the field
dictionary. (Inherited from DBObject) |
![]() |
GetField(String) | Returns the object ID of the specified field object (that
matches the property name) from the field dictionary. (Inherited from DBObject) |
![]() |
GetHashCode | (Inherited from DisposableWrapper) |
![]() |
GetLifetimeService | Retrieves the current lifetime service object that controls the
lifetime policy for this instance. (Inherited from MarshalByRefObject) |
![]() |
GetObjectSaveVersion(DwgFiler) | Returns the drawing and maintenance release version into which
this object must be stored. (Inherited from DBObject) |
![]() |
GetObjectSaveVersion(DxfFiler) | Returns the drawing and maintenance release version into which
this object must be stored. (Inherited from DBObject) |
![]() |
GetPersistentReactorIds | Returns the object IDs of this object's persistent
reactors. (Inherited from DBObject) |
![]() |
GetReactors | Obsolete. Returns this object's transient reactors. (Inherited from DBObject) |
![]() |
GetRXClass | (Inherited from RXObject) |
![]() |
GetTransientReactors | Returns this object's transient reactors. (Inherited from DBObject) |
![]() |
GetType | Gets the Type of the current
instance. (Inherited from Object) |
![]() |
GetXDataForApplication | Returns a linked list of ResBufs containing a copy of the XData
of this object. (Inherited from DBObject) |
![]() |
HandOverTo | Replaces this database-resident (DBRO) object with the
specified non-database-resident (NDBRO) object, while retaining
this object's objectId, handle, owner, and reactor list. (Inherited from DBObject) |
![]() |
HasContext | Checks whether the specified context exists in the
collection. (Inherited from DBObject) |
![]() |
HasPersistentReactor | Checks whether the passed identifier is an identifier of a
reactor attached to this object. (Inherited from DBObject) |
![]() |
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime
policy for this instance. (Inherited from MarshalByRefObject) |
![]() |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object) |
![]() |
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject
object. (Inherited from MarshalByRefObject) |
![]() |
QueryX | (Inherited from RXObject) |
![]() |
RegenSupportFlags | (Inherited from Drawable) |
![]() |
ReleaseExtensionDictionary | Releases and erases this object's extension dictionary if it
exists and is empty. (Inherited from DBObject) |
![]() |
RemoveContext | Removes a context from the collection. An active context can't
be removed. (Inherited from DBObject) |
![]() |
RemoveField | Removes the text field and returns its field ID. (Inherited from DBObject) |
![]() |
RemoveField(ObjectId) | Removes the specified field. (Inherited from DBObject) |
![]() |
RemoveField(String) | Removes the specified field by its name and returns its
ID. (Inherited from DBObject) |
![]() |
RemovePersistentReactor | Removes the specified persistent reactor from this object's
reactor list. (Inherited from DBObject) |
![]() |
ResetScaleDependentProperties | Resets object properties that depend on scale to the default
values. (Inherited from DBObject) |
![]() |
SetAttributes | Sets the vectorization attributes of this object, and returns
its attribute flags. (Inherited from Drawable) |
![]() |
SetField(Field) | Sets the specified field for the "TEXT" property. (Inherited from DBObject) |
![]() |
SetField(String, Field) | Sets the specified field for the specified property. (Inherited from DBObject) |
![]() |
SetFromStyle | Sets the annotative property of an object according to its
corresponding style, such as styles of text objects. (Inherited from DBObject) |
![]() |
SetObjectIdsInFlux | Called on a newly created cloned object to indicate that its
object ID is not valid. (Inherited from DBObject) |
![]() |
SetPaperOrientation | Sets the paper orientation property of a specified
object. (Inherited from DBObject) |
![]() |
SetSun | Sets a sun object for this viewport. (Inherited from AbstractViewTableRecord) |
![]() |
SetUcs(ObjectId) | Sets the UCS for the view or viewport table record. (Inherited from AbstractViewTableRecord) |
![]() |
SetUcs(OrthographicView) | Sets the UCS for the view or viewport table record. The new UCS
is unnamed and set according to the specified orthographic
view. (Inherited from AbstractViewTableRecord) |
![]() |
SetUcs(Point3d, Vector3d, Vector3d) | Sets the UCS for the view or viewport table record according to
the origin and x- and y-coordinate axes. (Inherited from AbstractViewTableRecord) |
![]() |
SetUcsToWorld | Sets the UCS for the view or viewport table record to the world
UCS. (Inherited from AbstractViewTableRecord) |
![]() |
SetViewDirection | Sets the view direction of the view or view table record
according to the specified orthographic view. (Inherited from AbstractViewTableRecord) |
![]() |
SubRegenSupportFlags | (Inherited from Drawable) |
![]() |
SubSetAttributes | (Inherited from DBObject) |
![]() |
SubViewportDraw | (Inherited from DBObject) |
![]() |
SubViewportDrawLogicalFlags | (Inherited from DBObject) |
![]() |
SubWorldDraw | (Inherited from DBObject) |
![]() |
SupportsCollection | Checks whether a particular context type is supported by this
object. This method shows whether an object supports a collection
type but does not show whether this object participates in any
contexts of that type. (Inherited from DBObject) |
![]() |
SwapIdWith | Swaps the objectIDs, handles, extended data (XData), and
extension dictionary between this object and another object. (Inherited from DBObject) |
![]() |
SwapReferences | This method performs object ID reference translations similar
to those done at the end of deep cloning. References between
objects in the workset have their object identifiers translated to
the swapped object identifiers of the referenced objects. In
contrast to cloning, this translation must occur in both
directions. Accordingly, it is possible to pass two different ID
maps in two different calls to this method. Currently not
implemented. (Inherited from DBObject) |
![]() |
ToString | Returns a string that represents the current object. (Inherited from Object) |
![]() |
UpgradeFromNotify | Upgrades the object from at least ForNotify mode to both ForNotify and ForWrite
modes. You should place a call to DowngradeToNotify() with no Open() or Close() methods
in between. For internal use. Currently not implemented. (Inherited from DBObject) |
![]() |
UpgradeOpen | (Inherited from DBObject) |
![]() |
ViewportDraw | Creates a viewport-dependent geometric representation of this
object. (Inherited from Drawable) |
![]() |
ViewportDrawLogicalFlags | Retrieves the setAttributes flags for the current
viewportDraw. (Inherited from Drawable) |
![]() |
WblockClone | Performs a shallow clone of this object. (Inherited from DBObject) |
![]() |
WorldDraw | Creates a viewport-independent geometric representation of this
object. (Inherited from Drawable) |
![]() |
X | (Inherited from RXObject) |
![]() |
XDataTransformBy | Applies the 3D transformation matrix to the XData of this
object. (Inherited from DBObject) |
Name | Description | |
---|---|---|
![]() |
Cancelled | (Inherited from DBObject) |
![]() |
Copied | Notification event called whenever the notifying object has had
its clone() member function called. (Inherited from DBObject) |
![]() |
Erased | Notification event called whenever an object has been erased or
unerased. (Inherited from DBObject) |
![]() |
Goodbye | Notification event called just before an object is deleted from
memory. (Inherited from DBObject) |
![]() |
Modified | Notification event called whenever an object is opened
ForWrite, a function has been called that
could modify the content of this object, and this object is now
being closed. (Inherited from DBObject) |
![]() |
ModifiedXData | Notification event called whenever the XData has been written
to the notifying object. (Inherited from DBObject) |
![]() |
ModifyUndone | Notification event called whenever the notifying object is
currently performing an undo operation that is undoing
modifications. (Inherited from DBObject) |
![]() |
ObjectClosed | Notification event called immediately before an object is
closed. (Inherited from DBObject) |
![]() |
OpenedForModify | Notification event called whenever an object is opened for
modifying ForWrite. (Inherited from DBObject) |
![]() |
Reappended | Notification event called whenever a redo process processes the
reappending of the notifying object to the database. (Inherited from DBObject) |
![]() |
SubObjectModified | (Inherited from DBObject) |
![]() |
Unappended | Notification event called whenever the undo process processes
the appending of the notifying object to the database. (Inherited from DBObject) |
© Bricsys NV. All rights reserved. |