MentalRayRenderSettings Class

This class is a container class for the properties related to mental ray renderers.
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.RuntimeRXObject
        Teigha.GraphicsInterfaceDrawable
          Teigha.DatabaseServicesDBObject
            Teigha.DatabaseServicesRenderSettings
              Teigha.DatabaseServicesMentalRayRenderSettings

Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public class MentalRayRenderSettings : RenderSettings

The MentalRayRenderSettings type exposes the following members.

Constructors
  Name Description
Public method MentalRayRenderSettings Default constructor for the MentalRayRenderSettings class.
Protected method MentalRayRenderSettings(IntPtr, Boolean) Initializes a new instance of the MentalRayRenderSettings class
Top
Properties
  Name Description
Public property DiagnosticBSPMode Property that represents the Diagnostic BSP Mode that is used.
Public property DiagnosticGridMode Property that represents available coordinate systems to use for the diagnostic grid.
Public property DiagnosticMode Property that represents available diagnostic visualization modes.
Public property DiagnosticPhotonMode Property that represents the type of photon information that is used in the photon diagnostic mode.
Public property EnergyMultiplier Property that represents the energy multiplier to control the magnitude of indirect illumination.
Public property ExportMIEnabled Property that indicates whether to export an MI file after an image is rendered.
Public property ExportMIFileName Property that represents a file name for an exported MI file.
Public property FGRayCount Property that represents the amount of final gather rays used for each final gather point.
Public property FGSampleRadius Property that represents the minimum and maximum final gather sample radii.
Public property FGSampleRadiusState Property that represents flags that indicate whether to use user-defined minimum and maximum final gather radii.
Public property FinalGatheringEnabled Property that indicates whether final gathering is enabled.
Public property FinalGatheringMode Property that represents the final gathering mode. Currently not implemented.
Public property GIPhotonsPerLight Property that represents the average number of photons to emit for each light source.
Public property GISampleCount Property that represents the maximum number of photons surrounding a render sample point to use for calculation of global illumination.
Public property GISampleRadius Property that represents the radius of the sample area of photons used for global illumination.
Public property GISampleRadiusEnabled Property that indicates whether a user-defined photon radius should be used.
Public property GlobalIlluminationEnabled Property that indicates whether global illumination effects (for example, color bleeding) should be enabled.
Public property LightLuminanceScale Property that represents the physical luminance of a light with intensity 1.0 (in candelas). Currently not implemented.
Public property MemoryLimit Property that represents the maximum amount of memory that can be allocated for rendering.
Public property PhotonTraceDepth Property that represents the maximum depth (recursion level) for traced photons. The MentalRayRenderSettingsTraitsTraceParameter parameter stores values for the maximum recursion level of reflection photons, maximum recursion level of refraction photons, and maximum recursion level of reflection and refraction photons, combined.
Public property RayTraceDepth Property that represents the maximum depth (recursion level) for traced rays. The MentalRayRenderSettingsTraitsTraceParameter parameter stores values for the maximum recursion level of reflection rays, maximum recursion level of refraction rays, and maximum recursion level of reflection and refraction rays, combined.
Public property RayTracingEnabled Property that indicates whether ray tracing is enabled.
Public property Sampling Property that represents the minimum and maximum number of samples that are used for the pixel shading process during rendering. The MentalRayRenderSettingsTraitsIntegerRangeParameter parameter stores values in the [-3..5] range. The value -3 corresponds to one sample for every 64 pixels (1/64), and the value 5 corresponds to 1024 samples per pixel.
Public property SamplingContrastColor Property that represents the threshold values for color channels, below which further samples are not accepted. The MentalRayRenderSettingsTraitsFloatParameter parameter stores values of red, green, blue and alpha channel values in the [0..1] range.
Public property SamplingFilter Property that represents the filtering parameters for merging multiple samples into a pixel color. The MentalRayRenderSettingsTraitsSamplingParameter parameter stores the following data: * Filtering method for merging multiple samples into a pixel color. * Width of a filter area for neighboring pixels in the range of [0..8]. * Height of a filter area for neighboring pixels in the range of [0..8].
Public property ShadowMapsEnabled Property that indicates whether shadow maps should be enabled. Affects only lights using mapped shadows.
Public property ShadowMode Property that represents the method used to compute ray-traced shadows. Affects only lights using ray-traced shadows.
Public property ShadowSamplingMultiplier Property that represents the shadow sampling multiplier value. Currently not implemented.
Public property TileOrder Property that represents the order used to render image tiles.
Public property TileSize Property that represents the size of the image tiles used during rendering. Small values increase rendering time but provide more frequent updates during rendering. The values must be in the range [4..512].
Top
Methods
  Name Description
Top
Events
  Name Description
Top
See Also

©  Bricsys NV. All rights reserved.