Overview
Copying Code Examples from the Bricscad Developer's Reference
LISP (LISt Processing)
LISP Functions
(+) (Addition operator)
(-) (Subtraction operator)
(*) (Multiplication operator)
(/) (Division operator)
(=) (Equal to operator)
(~) (1s compliment)
(/=) (Not equal to operator)
(<) (Less than operator)
(<=) (Less than or equal to operator)
(>) (Greater than operator)
(>=) (Greater than or equal to operator)
(1+)
(1-)
(abs)
(acad_colordlg)
(acad_strlsort)
(action_tile)
(add_list)
(ads)
(alert)
(alloc)
(and)
(angle)
(angtof)
(angtos)
(append)
(apply)
(ascii)
(assoc)
(atan)
(atof)
(atoi)
(atom)
(atoms-family)
(autoload)
(autoxload)
(boole)
(boundp)
(car)
(cdr)
(chr)
(client_data_table)
(close)
(command)
(cond)
(cons)
(cos)
(cvunit)
(defun)
(dimx_tile)
(dictadd)
(dictnext)
(dictremove)
(dictrename)
(dictsearch)
(dimy_tile)
(distance)
(distof)
(done_dialog)
(end_image)
(end_list)
(entdel)
(entget)
(entlast)
(entmake)
(entmakex)
(entmod)
(entnext)
(entsel)
(entupd)
(eq)
(equal)
(eval)
(*error*)
(exit)
(exp)
(expand)
(expt)
(fill_image)
(findfile)
(fix)
(float)
(foreach)
(gc)
(gcd)
(get_attr)
(get_tile)
(getangle)
(getcfg)
(getcname)
(getcorner)
(getdist)
(getenv)
(getfiled)
(getint)
(getkword)
(getorient)
(getpoint)
(getreal)
(getstring)
(getvar)
(graphscr)
(grclear)
(grdraw)
(grread)
(grtext)
(grvecs)
(handent)
(help)
(if)
(initget)
(inters)
(itoa)
(lambda)
(last)
(length)
(list)
(listp)
(load)
(load_dialog)
(log)
(log10)
(logand)
(logior)
(lpad)
(lsh)
(mapcar)
(max)
(mem)
(member)
(menucmd)
(menugroup)
(min)
(minusp)
(mode_tile)
(namedobjdict)
(nentsel)
(nentselp)
(new_dialog)
(not)
(nth)
(null)
(numberp)
(open)
(or)
(osnap)
pi
(polar)
(prin1)
(princ)
(print)
(progn)
(prompt)
(quit)
(quote)
(read)
(read-char)
(read-line)
(redraw)
(regapp)
(rem)
(repeat)
(reverse)
(rpad)
(rtos)
(set)
(set_tile)
(setcfg)
(setenv)
(setfunhelp
(setq)
(setvar)
(setview)
(sin)
(slide_image)
(snvalid)
(sqrt)
(ssadd)
(ssdel)
(ssget)
(ssgetfirst)
(sslength)
(ssmemb)
(ssname)
(ssnamex)
(sssetfirst)
(start_dialog)
(start_image)
(start_list)
(startapp)
(strcase)
(strcat)
(strlen)
(subst)
(substr)
(tan)
(tblnext)
(tblobjname)
(tblsearch)
(term_dialog)
(terpri)
(textbox)
(textpage)
(textscr)
(trace)
(trans)
(trim)
(type)
(unload_dialog)
(untrace)
(vector_image)
(ver)
(vmon)
(vports)
(wcmatch)
(while)
(write-char)
(write-line)
(xdroom)
(xdsize)
(xload)
(xunload)
(zerop)
LISP Compatibility
Additional functions
LISP Encryption
DCL (Dialog Control Language)
Predefined Attributes
About Predefined Attributes
action
alignment
allow_accept
aspect_ratio
big_increment
children_alignment
children_fixed_height
children_fixed_width
color
edit_limit
edit_width
fixed_height
fixed_width
fixed_width_font
height
initial_focus
is_bold
is_cancel
is_default
is_enabled
is_tab_stop
key
label
layout
list
lower_only
max_value
min_value
mnemonic
multiple_select
password_char
pointsize
read_only
small_increment
tabs
tab_truncate
typeface
upper_only
value
width
DCL Tiles
boxed_column
boxed_radio_column
boxed_radio_row
boxed_row
button
column
concatenation
edit_box
errtile
image
image_button
list_box
multi_edit_box
name
ok_cancel
ok_cancel_help
ok_cancel_help_errtile
ok_cancel_help_info
ok_only
paragraph
popup_list
radio_button
radio_column
radio_row
row
slider
spacer
spacer_0
spacer_1
text
text_part
toggle
VBA (Visual Basic for Applications)
Overview of automation
Using ActiveX Automation
Using the Object Model
Starting VBA
Inserting UserForms
Adding controls to a UserForm
Creating code
Using modules
Managing VBA projects
Running a VBA program
Events in Bricscad VBA
COM (Component Object Model)
The Bricscad Automation Object Model
User Guide
Drawing Lines and Arcs
Drawing Lines
Drawing Polylines
Drawing Arcs
Drawing Circles
Creating Other Objects
Creating Points
Creating Splines
Adding Hatching
Adding Text to Drawings
Creating Single-Line Text
Creating Paragraph Text
Working with Text Styles
Working with Views
Using Named Views
Using Viewports
Working in Three Dimensions
Creating Three-Dimensional Objects
Reference Guide
Objects
AcCmColor Object
Application object
ApplicationPreferences object
Arc object
Attribute object
AttributeReference object
Block object
BlockReference object
Blocks collection object
Circle object
Dictionary object
Dictionaries collection object
Dim3PointAngular object
DimAligned object
DimAngular object
DimDiametric object
Dimension object
DimensionStyle object
DimensionStyles collection object
DimOrdinate object
DimRadial object
DimRotated object
Document object
DocumentPreferences object
Documents collection object
Ellipse object
Entity object
ExternalReference object
Face3D object
Group object
Groups collection object
Hyperlink object
Hyperlinks collection object
Hatch object
Image object
InfiniteLine object
Layer object
Layers collection object
Layout object
Layouts collection object
Leader object
Line object
Linetype object
Linetypes collection object
LWPolyline object
MenuBar object
MenuGroup object
MenuGroups object
ModelSpace collection object
MText object
PaperSpace collection object
PlotConfiguration object
PlotConfigurations collection object
Plot object
Point object
PolyfaceMesh object
PolygonMesh object
Polyline object
Polyline3D object
PopupMenu object
PopupMenus object
PopupMenuItem object
Preferences object
PViewport object
Ray object
Region object
RegisteredApplication object
RegisteredApplications collection object
SelectionSet object
SelectionSets collection object
Shape object
Solid object
Solid3D object
SolidCreator 0bject
Spline object
Text object
TextStyle object
TextStyles collection object
Tolerance object
Toolbar object
Toolbars object
Trace object
UserCoordSystem object
UserCoordSystems collection object
Utility object
View object
Views collection object
Viewport object
Viewports collection object
Window object
Windows collection object
Workspace object
XRecord object
Properties
ActiveDocument property
AltFontFile property
Application property
Area property
AutoSaveInterval property
Caption property
Center property
CenterPlot property
Circumference property
Closed property
Color property
Constant property
ContourLinesPerSurface property
Coordinates property
Count property
CursorSize property
Diameter property
DisplayScrollBars property
DisplaySilhouette property
DockedVisibleLines property
Document property
Documents property
EndAngle property
EndPoint property
FieldLength property
FullName property
GraphicsWinBackgrndColor property
Handle property
HasAttributes property
HasExtensionDictionary property
Height property
HideLines property
HistoryLines property
HorizontalAlignment property
ImageFile property
ImageHeight property
ImageVisibility property
ImageWidth property
Index property
InsertionPoint property
Invisible property
IsXRef property
Item property
Layer property
Length property
Linetype property
LinetypeScale property
LineWeight property
LocaleID property
LogFilePath property
LogFileOn property
MaxActiveViewports property
MaxAutoCADWindow property
Mode property
Name property
Normal property
ObjectName property
ObliqueAngle property
Origin property
PaperOrientation property
PaperSpace property
Path property
Pens property
PenWidth property
PlotManager property
PlotStyleName property
Preferences property
Preset property
PromptString property
Radius property
ReadOnly property
RenderSmoothness property
Rotation property
Saved property
ScaleFactor property
SegmentPerPolyline property
SolidFill property
StartAngle property
StartPoint property
StyleName property
TagString property
TextAlignmentPoint property
TextFrameDisplay property
TextGenerationFlag property
TextString property
Thickness property
Units property
URL property
VBE property
Verify property
Version property
VerticalAlignment property
View property
VisibilityEdgeX property
Visible property
Width property
WindowTop property
XRefLayerVisibility property
XScaleFactor property
YScaleFactor property
ZScaleFactor property
Methods
Activate method
Add method
Add3dFace method
Add3DMesh method
Add3dPoly method
AddArc method
AddBox method
AddAttributeDef method
AddCircle method
AddCone method
AddCylinder method
AddDimAligned method
AddDim3PointAngular method
AddDimAngular method
AddDimDiametric method
AddDimOrdinate method
AddDimRadial method
AddDimRotated method
AddEllipse method
AddFitPoint method
AddHatch method
AddImage method
AddXLine method
AddItems method
AddLeader method
AddLightWeightPolyline method
AddLine method
AddMtext method
AddPointEntity method
AddPolyfaceMesh method
AddPolyline method
AddPViewport method
AddRay method
AddSolid method
AddSphere method
AddSpline method
AddText method
AddTolerance method
AddTorus method
AddTrace method
AddVertex method
AddWedge method
AngleFromXAxis method
AngleToReal method
AngleToString method
AppendVertex method
ArrayPolar method
ArrayRectangular method
AttachExternalReference method
Bind method
Clear method
Close method
Copy method
Delete method
DefineFunction method
DeleteFitPoint method
Detach method
Display method
Erase method
Explode method
Export method
GetAngle method
GetAttributes method
GetBoundingBox method
GetBulge method
GetControlPoint method
GetCorner method
GetExtensionDictionary method
GetGridSpacing method
GetInterfaceObject method
GetInvisibleEdge method
GetSnapSpacing method
GetUCSMatrix method
GetVariable method
GetWidth method
GetXData method
GetXData and SetXData Method Example
HandleToObject method
Highlight method
Import method
InsertBlock method
IntersectWith method
Item method
Mirror method
Mirror3D method
Move method
Offset method
Open method
DisplayPlotPreview method
Parent method
PlotToDevice method
PlotToFile method
PurgeAll method
Quit method
Regen method
Reload method
RemoveItems method
Rotate method
Rotate3D method
RunCommand method
RunScript method
Save method
SaveAs method
ScaleEntity method
Select method
SelectAtPoint method
SelectByPolygon method
SelectOnScreen method
SetBulge method
SetGridSpacing method
SetInvisibleEdge method
SetPattern method
SetSnapSpacing method
SetVariable method
SetView method
SetWidth method
SetXData method
Split method
TransformBy method
UndefineFunction method
Unload method
Update method
WBlock method
ZoomAll method
ZoomCenter method
ZoomExtents method
ZoomPickWindow method
ZoomScaled method
ZoomWindow method
Constants
AcActiveSpace
AcAngleUnits
AcArrowheadType
AcAttachmentPoint
AcAttributeMode
AcColor
AcCoordinateSystem
AcDimCenterType
AcBooleanType
AcDimFit
AcDimFractionType
AcDimHorizontalJustification
AcDimLUnits
AcDimPrecision
AcDimTextMovement
AcDimToleranceJustify
AcDimToleranceMethod
AcDimVerticalJustification
AcDrawingDirection
AcEntityName
AcExtendOption
AcHatchStyle
AcMenuGroupType
AcMenuItemType
AcPatternType
AcSaveAsType
AcHorizontalAlignment
AcLineWeight
AcPlotPaperUnits
AcPlotRotation
AcPlotScale
AcPlotType
AcRegenType
AcLeaderType
AcPlotOrientation
AcPolymeshType
AcPolylineType
AcSelect
AcTextGenerationFlag
AcTextFontStyle
AcUnits
AcVerticalAlignment
AcViewportScale
AcViewportSplitType
AcWindowState
AcZoomScaleType
BRX (Bricscad Runtime eXtension)
DRX (DwgDirect Runtime eXtension)
SDS (deprecated)
Supported SDS functions
SDS-DCL functions
Bricscad V9
User Guide
Command Reference
System Variables