DBText Class |
The DBText type exposes the following members.
Name | Description | |
---|---|---|
![]() |
![]() |
AlignmentPoint | Property that represents the alignment point of this text. |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
Height | Property that represents the height of this text. |
![]() |
HorizontalMode | Property that represents the horizontal mode for this text. |
![]() |
![]() |
![]() |
![]() |
![]() |
IsDefaultAlignment | Property that indicates whether this text entity is in the default alignment. |
![]() |
![]() |
![]() |
![]() |
IsMirroredInX | Property that indicates whether this text is mirrored about the x-axis. |
![]() |
IsMirroredInY | Property that indicates whether this text is mirrored about the y-axis. |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
Justify | Property that represents the justification point(s) of the text. |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
Normal | Property that represents the normal to the plane where this text lies. |
![]() |
![]() |
![]() |
Oblique | Property that represents the oblique angle (in radians) in the range of equivalent [-85..+85] degrees. |
![]() |
![]() |
![]() |
![]() |
![]() |
Position | Property that represents the WCS position of this text entity. |
![]() |
![]() |
Rotation | Property that represents the rotation of this text. |
![]() |
TextString | Property that represents a string message for this text object. |
![]() |
TextStyleId | Property that represents the text style applied to this text. |
![]() |
TextStyleName | Property that represents the name of the text style applied to this object. |
![]() |
Thickness | Property that represents the thickness of this text. |
![]() |
![]() |
![]() |
![]() |
VerticalMode | Property that represents the vertical mode for this text. |
![]() |
![]() |
![]() |
WidthFactor | Property that represents the width of this text. |
![]() |
Name | Description | |
---|---|---|
![]() |
![]() |
![]() |
![]() |
AdjustAlignment | Adjusts the position of this text entity if its alignment is not left baseline. |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
ConvertFieldToText | Converts the fields in this text entity to text, and removes the fields. |
![]() |
![]() |
CorrectSpelling | Invokes the spell checker on this text entity. |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
GetGraphicsMarkersAtSubentityPathIntPtr | Entities use a mechanism of graphics system markers to draw
themselves. This mechanism associates an integer identifier called
a graphics system marker (or, GS marker) with each primitive or
with groups of primitives. Using specific selection mechanisms, the
GS marker for the actual subentity selected on the screen can be
retrieved and used for various purposes, for example
highlighting/unhighlighting the subentity on the screen,
hiding/unhiding it, etc. This method returns all graphics system
markers by subentity paths for complex entities that have the
ability to associate an integer identifier (GS marker) with each
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
getTextWithFieldCodes | |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
SwapReferences | This method performs object ID reference translations similar
to those done at the end of deep cloning. References between
objects in the workset have their object identifiers translated to
the swapped object identifiers of the referenced objects. In
contrast to cloning, this translation must occur in both
directions. Accordingly, it is possible to pass two different ID
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
Name | Description | |
---|---|---|
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
© Bricsys NV. All rights reserved. |