MLeader Class |
The MLeader type exposes the following members.
Name | Description | |
---|---|---|
![]() |
MLeader | Default constructor for the MLeader class. |
![]() |
MLeader(IntPtr, Boolean) | Initializes a new instance of the MLeader class |
Name | Description | |
---|---|---|
![]() |
![]() |
![]() |
ArrowSize | Property that represents the arrow size for this MLeader object. |
![]() |
ArrowSymbolId | Property that represents the arrow symbol for this multileader (as an ObjectId object). |
![]() |
![]() |
BlockColor | Property that represents the color used for block content. |
![]() |
BlockConnectionType | Property that represents the block connection type for this multileader, which specifies how the referenced block is connected to the leader lines. |
![]() |
BlockContentId | Property that represents the referenced block for this multileader (as an ObjectId object). |
![]() |
![]() |
![]() |
BlockPosition | Property that represents the position for the block referenced by this multileader. |
![]() |
BlockRotation | Property that represents the rotation used by the referenced block. |
![]() |
BlockScale | Property that represents the scale used by the referenced block. |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
ContentType | Property that represents the content type for this MLeader object. |
![]() |
![]() |
DoglegLength | Property that represents the length of a dog-leg leader line. |
![]() |
![]() |
![]() |
![]() |
![]() |
EnableAnnotationScale | Property that indicates whether annotation scaling is enabled for this multileader. |
![]() |
EnableDogleg | Property that indicates whether the dog-leg leader line is enabled. |
![]() |
EnableFrameText | Property that indicates whether the text frame is visible for multiline text content. |
![]() |
EnableLanding | Property that indicates whether the leader landing line is enabled. |
![]() |
![]() |
ExtendLeaderToText | Property that indicates whether horizontal leader lines are automatically extended to the text. |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
LandingGap | Property that represents the landing gap for this multileader (gap between the leader tail and associated multiline text). |
![]() |
![]() |
![]() |
LeaderCount | Obsolete. Property that represents the count of leaders for this MLeader object. Currently not implemented. Use the GetLeaderIndexes method instead. |
![]() |
LeaderLineColor | Property that represents the leader line color for this MLeader object. |
![]() |
LeaderLineCount | Obsolete. Property that represents the count of leader lines for this MLeader object. Currently not implemented. Use the GetLeaderLineIndexes method instead. |
![]() |
LeaderLineType | Property that represents the leader linetype for this MLeader object. |
![]() |
LeaderLineTypeId | Property that represents the leader linetype (as an ObjectID object) for this MLeader object. |
![]() |
LeaderLineWeight | Property that represents the leader lineweight for this multileader. |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
MLeaderStyle | Property that represents the multileader style (as Object ID object) used for this multileader. |
![]() |
MText | Property that represents the multiline text content associated with this multileader. |
![]() |
Normal | Property that represents the normal vector to the plane that contains this multileader. |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
Scale | Property that represents the multileader scale, which affects arrowhead size and content scale. |
![]() |
TextAlignmentType | Property that represents the text alignment type for multiline text content. |
![]() |
TextAngleType | Property that represents the angle type for multiline text content, with respect to the last leader line segment. |
![]() |
TextAttachmentDirection | Property that represents the text attachment direction of multiline text. |
![]() |
TextAttachmentType | Property that represents the text attachment type used by multiline text content. |
![]() |
TextColor | Property that represents the text color for multiline text content. |
![]() |
TextHeight | Property that represents the text height for multiline text content. |
![]() |
TextLocation | Property that represents the location for the multiline text content associated with this multileader. |
![]() |
TextStyleId | Property that represents the object ID of a text style used by multiline text content. |
![]() |
ToleranceLocation | Property that represents the location for multileader tolerance content. |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
Name | Description | |
---|---|---|
![]() |
![]() |
AddFirstVertex | Inserts a new first vertex into the specified leader line. |
![]() |
AddLastVertex | Appends a new last vertex to the specified leader line. |
![]() |
AddLeader | Adds a new leader cluster to this MLeader object and returns the index of the new cluster. |
![]() |
AddLeaderLine(Int32) | Adds a leader line to the leader cluster specified by the passed index and returns the index of the newly added leader line. |
![]() |
AddLeaderLine(Point3d) | Adds a new leader line to this MLeader object and returns the index of the newly added leader line. |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
ConnectionPoint(Vector3d) | Returns the connection point of this multileader for the specified direction. |
![]() |
ConnectionPoint(Vector3d, TextAttachmentDirection) | Returns the connection point of this multileader for the specified direction. |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
GetArrowSize | Returns the arrow size for the specified leader line. |
![]() |
GetArrowSymbolId | Returns the object ID of the arrow head symbol for a specified leader line. |
![]() |
GetBlockAttribute | Returns the object ID of the arrowhead symbol for a specified leader line. |
![]() |
GetContentGeomExtents | Returns the the extents of the content for this multileader. |
![]() |
getContextDataManager | Returns the context data manager for this multileader. |
![]() |
GetDogleg | Returns the dog-leg direction for the specified leader cluster. |
![]() |
GetDoglegLength | Returns the length for the dog-leg of the specified leader cluster. |
![]() |
![]() |
![]() |
![]() |
GetFirstVertex | Returns the first vertex of the specified leader line. |
![]() |
GetGraphicsMarkersAtSubentityPathIntPtr | Entities use a mechanism of graphics system markers to draw
themselves. This mechanism associates an integer identifier called
a graphics system marker (or, GS marker) with each primitive or
with groups of primitives. Using specific selection mechanisms, the
GS marker for the actual subentity selected on the screen can be
retrieved and used for various purposes, for example
highlighting/unhighlighting the subentity on the screen,
hiding/unhiding it, etc. This method returns all graphics system
markers by subentity paths for complex entities that have the
ability to associate an integer identifier (GS marker) with each
![]() |
![]() |
![]() |
![]() |
![]() |
GetLastVertex | Returns the last vertex of the specified leader line. |
![]() |
GetLeaderIndex | Returns the index of the leader cluster that contains the specified leader line. |
![]() |
GetLeaderIndexes | Returns the indexes of leaders. |
![]() |
GetLeaderLineColor | Returns the leader line color for the specified leader line. |
![]() |
GetLeaderLineIndexes | Returns the indexes of all leader lines for the specified leader. |
![]() |
GetLeaderLineType | Returns the leader linetype for the specified leader line. |
![]() |
GetLeaderLineTypeId | Returns the object ID of a leader linetype used for the specified leader line. |
![]() |
GetLeaderLineWeight | Returns the leader lineweight for the specified leader line. |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
getOverridedMLeaderStyle | Returns the property set for the multileader, including override values. |
![]() |
![]() |
GetPlane | Return the WCS plane that contains this multileader
object. (Overrides EntityGetPlane) |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
GetTextAttachmentType | Returns the text attachment type used by multiline text content. |
![]() |
![]() |
![]() |
![]() |
GetVertex | Returns the position of a specified vertex in a specified leader line. |
![]() |
![]() |
![]() |
HasContent | Checks whether this multileader has content. |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
MoveMLeader | Moves this MLeader object by the specified vector. |
![]() |
![]() |
PostMLeaderToDb | Adds this MLeader object to the model space block of the specified database. |
![]() |
![]() |
recomputeBreakPoints | Recomputes the dimension break points. |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
RemoveFirstVertex | Removes the first vertex from the specified leader line. |
![]() |
RemoveLastVertex | Removes the last vertex from the specified leader line. |
![]() |
RemoveLeader | Removes the leader cluster located at the specified index. |
![]() |
RemoveLeaderLine | Removes the leader line located at the specified index. |
![]() |
![]() |
![]() |
![]() |
SetArrowSize | Sets the arrow size for the specified leader line. |
![]() |
SetArrowSymbolId | Sets the arrowhead symbol for the specified leader line. |
![]() |
![]() |
SetBlockAttribute | Sets the specified attribute within associated block content. |
![]() |
SetContextDataManager | Sets the context data manager for this MLeader object. |
![]() |
![]() |
![]() |
SetDogleg | Sets the dog-leg direction for the specified leader cluster. |
![]() |
SetDoglegLength | Sets the length for the dog-leg of the specified leader cluster. |
![]() |
![]() |
![]() |
![]() |
SetFirstVertex | Sets the first vertex of the specified leader line. |
![]() |
![]() |
![]() |
SetLastVertex | Sets the first vertex of the specified leader line. |
![]() |
![]() |
SetLeaderLineColor | Sets the leader line color for the specified leader line. |
![]() |
SetLeaderLineType | Sets the leader linetype for the specified leader line. |
![]() |
SetLeaderLineTypeId | Sets the leader linetype for the specified leader line. |
![]() |
SetLeaderLineWeight | Sets the leader lineweight for the specified leader line. |
![]() |
![]() |
![]() |
SetPlane | Sets the WCS plane containing this MLeader object. |
![]() |
![]() |
![]() |
SetTextAttachmentType | Sets the text attachment type used by multiline text content. |
![]() |
SetVertex | Sets the position for a vertex in the specified leader line. |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
SwapReferences | This method performs object ID reference translations similar
to those done at the end of deep cloning. References between
objects in the workset have their object identifiers translated to
the swapped object identifiers of the referenced objects. In
contrast to cloning, this translation must occur in both
directions. Accordingly, it is possible to pass two different ID
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
VerticesCount | Returns the number of vertices in the specified leader line. |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
Name | Description | |
---|---|---|
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
© Bricsys NV. All rights reserved. |