Light Class

This class represents a placeholder for all generic light properties that are stored in a database.
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.RuntimeRXObject
        Teigha.GraphicsInterfaceDrawable
          Teigha.DatabaseServicesDBObject
            Teigha.DatabaseServicesEntity
              Teigha.DatabaseServicesLight

Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public class Light : Entity

The Light type exposes the following members.

Constructors
  Name Description
Public method Light Default constructor for the Light class.
Protected method Light(IntPtr, Boolean) Initializes a new instance of the Light class
Top
Properties
  Name Description
Public property Attenuation Property that represents light attenuation limits information.
Public property AttenuationType Property that represents the light attenuation type.
Public property Direction Property that represents the direction of a distant light.
Public property EndLimitOffset Property that represents the end limit parameter of light attenuation.
Public property FalloffAngle Property that represents the cone angle that produces the light falloff.
Public property GlyphDisplayType Property that represents the glyph display type of this light.
Public property HasTarget Property that indicates whether this light displays a target grip to orient the light.
Public property HotspotAngle Property that represents the cone angle that produces the brightest part of the beam (hotspot) of this light.
Public property IlluminanceDistance Property that represents the illuminance distance of the light.
Public property Intensity Property that represents the intensity of this light.
Public property IsOn Property that indicates whether this light is enabled.
Public property IsPlottable Property that indicates whether this light is shown during plotting.
Public property LampColorPreset Property that represents the preset lamp color of this light.
Public property LampColorRGB Property that represents the RGB value of the light's lamp color.
Public property LampColorTemp Property that represents the Kelvin color temperature of the light if the lamp color type is Kelvin.
Public property LampColorType Property that represents the lamp color type of the light that indicates how the lamp color of the light is specified (Kelvin color temperature or a preset lamp color).
Public property LightColor Property that represents the color of this light.
Public property LightType Property that represents the type of this light which can be DistantLight, PointLight, SpotLight or WebLight.
Public property MapSize Property that represents the shadow map size. Possible values: 64, 128, 256, 512, 1024, 2048, or 4096.
Public property Name Property that represents the light name.
Public property PhysicalIntensity Property that represents the physical intensity of the light. The units are based on the physical intensity method (candela, lumen or lux).
Public property PhysicalIntensityMethod Property that represents the physical intensity method of this light that indicates how the physical intensity of the light is calculated (by peak intensity, by flux or by illuminance).
Public property Position Property that represents the position for point light and spot light sources.
Public property Shadow Property that represents the shadow parameters for this light.
Public property ShadowType Property that represents the shadow type for this light.
Public property Softness Property that represents the softness shadow parameter.
Public property StartLimitOffset Property that represents the start limit parameter of light attenuation.
Public property TargetLocation Property that represents the target location of a light.
Public property UseLimits Property that indicates whether light attenuation limits are used.
Public property WebFile Property that represents the full path to the file that stores the light's goniometric data (IES file).
Public property WebRotation Property that represents the rotation offset used to orient the goniometric data relative to the light orientation.
Top
Methods
  Name Description
Public method ResultingColor Retrieves the final color of the light as a result of mixing the lamp color and the filter color.
Public method SetHotspotAndFalloff Specifies the hotspot and falloff for the cone of the directional light.
Top
Events
  Name Description
Top
See Also

©  Bricsys NV. All rights reserved.