MText Class

This class represents paragraph (multiline) text (MText) entities in a database.
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.RuntimeRXObject
        Teigha.GraphicsInterfaceDrawable
          Teigha.DatabaseServicesDBObject
            Teigha.DatabaseServicesEntity
              Teigha.DatabaseServicesMText

Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public class MText : Entity

The MText type exposes the following members.

Constructors
  Name Description
Public method MText Default constructor for the MText class.
Protected method MText(IntPtr, Boolean) Initializes a new instance of the MText class
Top
Properties
  Name Description
Public property ActualHeight Property that represents the actual height of this MText entity (depends on contents).
Public property ActualWidth Property that represents the actual width of the bounding box of this MText entity (depends on contents).
Public propertyStatic member AlignChange Property that represents the alignment change string "\A". Can be used in place of "\A" to make code more understandable.
Public property Ascent Property that represents the height of the maximum ascender for the first line of this MText entity.
Public property Attachment Property that represents the type of attachment point of this MText entity.
Public property BackgroundFill Property that indicates whether the background filling is turned on for this MText entity.
Public property BackgroundFillColor Property that represents the background fill color of this MText entity.
Public property BackgroundScaleFactor Property that represents the background scale factor of this MText entity.
Public property BackgroundTransparency Property that represents the background transparency of this MText entity.
Public propertyStatic member BlockBegin Property that represents the begin block string "{". Can be used in place of "{" to make code more understandable.
Public propertyStatic member BlockEnd Property that represents the begin block string "}". Can be used in place of "}" to make code more understandable.
Public propertyStatic member ColorChange Property that represents the color change string "\C". Can be used in place of "\C" to make code more understandable.
Public property ColumnAutoHeight Property that indicates whether dynamic columns use the MText height or a per-column user-defined height.
Public property ColumnCount Property that represents the column count of this MText entity.
Public property ColumnFlowReversed Property that indicates whether column flow is reversed for this MText. This property affects how columns are added.
Public property ColumnGutterWidth Property that represents the column gutter width of this MText entity.
Public property ColumnType Property that represents the column type of this MText entity. The type can be one of the following: NameValueNoColumns 1 StaticColumns 2 DynamicColumns 3
Public property ColumnWidth Property that represents the width used for every column.
Public property Contents Property that represents a copy of the character content of this MText entity.
Public property Descent Property that represents the height of the maximum descender for the last line of this MText entity.
Public property Direction Property that represents the WCS x-axis direction vector of this MText entity.
Public property FlowDirection Property that represents the flow direction of the multiline text.
Public propertyStatic member FontChange Property that represents the font change string "\F". Can be used in place of "\F" to make code more understandable.
Public property Height Property that represents the height of the bounding box of this MText entity.
Public propertyStatic member HeightChange Property that represents the height change string "\H". Can be used in place of "\H" to make code more understandable.
Public propertyStatic member LineBreak Property that represents the line break string "\p". Can be used in place of "\p" to make code more understandable.
Public property LineSpaceDistance Property that represents the spacing between text lines.
Public property LineSpacingFactor Property that represents the line spacing factor in the range [0.25 .. 4.0].
Public property LineSpacingStyle Property that represents the line spacing style that defines how spacing is applied according to character sizes.
Public property Location Property that represents the insertion point of this MText entity.
Public propertyStatic member NonBreakSpace Property that represents the non-break space string "\~". Can be used in place of "\~" to make code more understandable.
Public property Normal Property that represents the WCS normal to the plane that contains this MText entity.
Public propertyStatic member ObliqueChange Property that represents the oblique angle change string "\Q". Can be used in place of "\Q" to make code more understandable.
Public propertyStatic member OverlineOff Property that represents the overline off string "\o". Can be used in place of "\o" to make code more understandable.
Public propertyStatic member OverlineOn Property that represents the overline on string "\O". Can be used in place of "\O" to make code more understandable.
Public propertyStatic member ParagraphBreak Property that represents the paragraph break string "\P". Can be used in place of "\P" to make code more understandable.
Public property Rotation Property that represents the rotation angle of this MText entity in radians.
Public property ShowBorders Property that indicates whether to display multiline text borders.
Public propertyStatic member StackStart Property that represents the stacked text start string "\S". Can be used in place of "\S" to make code more understandable.
Public property Text Property that represents the text content without format codes.
Public property TextHeight Property that represents the text height of this MText entity.
Public property TextStyle Obsolete.
Property that represents the object ID of the text style used for this MText entity.
Public property TextStyleId Property that represents the object ID of the text style used for this MText entity.
Public property TextStyleName Property that represents the name of the text style used for this MText entity.
Public propertyStatic member TrackChange Property that represents the track change string "\T". Can be used in place of "\T" to make code more understandable.
Public propertyStatic member UnderlineOff Property that represents the underline off string "\l". Can be used in place of "\l" to make code more understandable.
Public propertyStatic member UnderlineOn Property that represents the underline on string "\L". Can be used in place of "\L" to make code more understandable.
Public property UseBackgroundColor Property that indicates whether the screen background color is used as the background color of this MText entity.
Public property Width Property that represents the word-wrap width of this MText entity. Words exceeding this value extend beyond this width.
Public propertyStatic member WidthChange Property that represents the width change string "\W". Can be used in place of "\W" to make code more understandable.
Top
Methods
  Name Description
Public method ConvertFieldToText Converts the fields in this MText entity to text, and removes the fields.
Public method CorrectSpelling Runs the spell checker to correct spelling errors.
Public method ExplodeFragments(MTextFragmentCallback) Explodes this MText entity into a sequence of simple text fragments, passing each fragment to the specified function.
Public method ExplodeFragments(MTextFragmentCallback, Object) Explodes this MText entity into a sequence of simple text fragments, passing each fragment to the specified function.
Public method ExplodeFragments(MTextFragmentCallback, Object, WorldDraw) Explodes this MText entity into a sequence of simple text fragments, passing each fragment to the specified function.
Public method GetBoundingPoints Returns the WCS bounding points of this MText entity box. The points are returned as follows: PointCornerboundingPoints[0] Top left boundingPoints[1] Top right boundingPoints[2] Bottom left boundingPoints[3] Bottom right
Public method GetColumnHeight Returns the column height of this MText entity.
Public method getMTextWithFieldCodes  
Public method SetAttachmentMovingLocation Sets the type of the attachment point of this MText entity.
Public method SetColumnHeight Sets the column height of this MText entity.
Public method SetContentsRtf Sets the character content of this MText entity from the RTF-encoded text string.
Public method SetDynamicColumns Sets the column type to DynamicColumns with the specified width, gutter and auto-height setting.
Public method SetStaticColumns Sets the column type to StaticColumns with the specified width, gutter and count of columns.
Top
Events
  Name Description
Top
See Also

©  Bricsys NV. All rights reserved.