Table
|
The TableContent type exposes the following members.
Name | Description | |
---|---|---|
![]() |
TableContent | Default constructor for the TableContent class. |
![]() |
TableContent(IntPtr, Boolean) | Initializes a new instance of the TableContent class |
Name | Description | |
---|---|---|
![]() |
AcadObject | (Inherited from DBObject) |
![]() |
Annotative | (Inherited from DBObject) |
![]() |
AutoDelete | (Inherited from DisposableWrapper) |
![]() |
Bounds | (Inherited from Drawable) |
![]() |
ClassID | (Inherited from DBObject) |
![]() |
Database | (Inherited from DBObject) |
![]() |
Drawable | Property that represents a drawable that is associated with
this object. (Inherited from DBObject) |
![]() |
DrawableType | (Inherited from Drawable) |
![]() |
ExtensionDictionary | (Inherited from DBObject) |
![]() |
Handle | (Inherited from DBObject) |
![]() |
HasFields | (Inherited from DBObject) |
![]() |
HasSaveVersionOverride | (Inherited from DBObject) |
![]() |
Id | Property that represents an object identifier of this database
object. (Inherited from DBObject) |
![]() |
IsAProxy | (Inherited from DBObject) |
![]() |
IsCancelling | (Inherited from DBObject) |
![]() |
IsDisposed | (Inherited from DisposableWrapper) |
![]() |
IsEmpty | Property that indicates whether this object does not contain
data. Should be implemented in the derived classes. (Inherited from LinkedData) |
![]() |
IsErased | (Inherited from DBObject) |
![]() |
IsEraseStatusToggled | (Inherited from DBObject) |
![]() |
IsModified | (Inherited from DBObject) |
![]() |
IsModifiedGraphics | (Inherited from DBObject) |
![]() |
IsModifiedXData | (Inherited from DBObject) |
![]() |
IsNewObject | (Inherited from DBObject) |
![]() |
IsNotifyEnabled | (Inherited from DBObject) |
![]() |
IsNotifying | (Inherited from DBObject) |
![]() |
IsObjectIdsInFlux | (Inherited from DBObject) |
![]() |
IsPersistent | Property that indicates whether this object is a
database-resident (DBRO). Persistent objects belong to an object
that must be opened and closed. Non-persistent objects can be
accessed through their pointers. (Inherited from DBObject) |
![]() |
IsReadEnabled | (Inherited from DBObject) |
![]() |
IsReallyClosing | (Inherited from DBObject) |
![]() |
IsTransactionResident | (Inherited from DBObject) |
![]() |
IsUndoing | (Inherited from DBObject) |
![]() |
IsWriteEnabled | (Inherited from DBObject) |
![]() |
MergeStyle | (Inherited from DBObject) |
![]() |
Name | Property that represents the name of the data. (Inherited from LinkedData) |
![]() |
NumberOfColumns | Property that represents the number of columns in this linked
table object. (Inherited from LinkedTableData) |
![]() |
NumberOfRows | Property that represents the number of rows in this linked
table object. (Inherited from LinkedTableData) |
![]() |
ObjectBirthVersion | (Inherited from DBObject) |
![]() |
ObjectId | (Inherited from DBObject) |
![]() |
OwnerId | (Inherited from DBObject) |
![]() |
PaperOrientation | (Inherited from DBObject) |
![]() |
TableStyleId | Property that represents the table style identifier. |
![]() |
UndoFiler | (Inherited from DBObject) |
![]() |
UnmanagedObject | (Inherited from DisposableWrapper) |
![]() |
XData | (Inherited from DBObject) |
Name | Description | |
---|---|---|
![]() |
AddContext | Adds a copy of a context to the object. (Inherited from DBObject) |
![]() |
AddPersistentReactor | Adds the specified persistent reactor to this object's reactor
list. (Inherited from DBObject) |
![]() |
AppendColumn | Appends the specified number of columns into this linked table
object. (Inherited from LinkedTableData) |
![]() |
AppendRow | Appends the specified number of rows into this linked table
object. (Inherited from LinkedTableData) |
![]() |
ApplyPartialUndo | Notification method that is called each time this object uses
the partial undo mechanism. (Inherited from DBObject) |
![]() |
AssertNotifyEnabled | (Inherited from DBObject) |
![]() |
AssertReadEnabled | (Inherited from DBObject) |
![]() |
AssertWriteEnabled | (Inherited from DBObject) |
![]() |
Audit | Performs an audit operation on this object. (Inherited from DBObject) |
![]() |
Cancel | Obsolete. Terminates the current open operation. Currently not implemented. (Inherited from DBObject) |
![]() |
Clear | Deletes the data. Should be implemented in the derived
classes. (Inherited from LinkedData) |
![]() |
Clone | (Inherited from RXObject) |
![]() |
Close | Obsolete. Closes the object. All changes made to the object since it was opened are committed to the database and a notification is sent that the object is now "closed". Currently not implemented. (Inherited from DBObject) |
![]() |
CloseAndPage | Obsolete. Closes the object and pages it if the object pager is enabled. All changes made to the object since it was opened are committed to the database and a notification is sent that the object is now "closed". Currently not implemented. (Inherited from DBObject) |
![]() |
CompareTo | (Inherited from RXObject) |
![]() |
CopyFrom | (Inherited from RXObject) |
![]() |
CreateExtensionDictionary | Creates a DbDictionary extension dictionary of this
object. (Inherited from DBObject) |
![]() |
CreateObjRef | Creates an object that contains all the relevant information
required to generate a proxy used to communicate with a remote
object. (Inherited from MarshalByRefObject) |
![]() |
DataType | Returns the data type of the first content of the specified
cell. (Inherited from LinkedTableData) |
![]() |
DecomposeForSave | Determines the behavior for custom objects when saving to a
.dwg file. (Inherited from DBObject) |
![]() |
DeepClone | Performs a deep clone of this object. (Inherited from DBObject) |
![]() |
DeleteColumn | Deletes the specified number of columns from this linked table
object. (Inherited from LinkedTableData) |
![]() |
DeleteContent | Deletes content from a cell. (Inherited from LinkedTableData) |
![]() |
DeleteRow | Deletes the specified number of rows from this linked table
object. (Inherited from LinkedTableData) |
![]() |
DeleteUnmanagedObject | (Inherited from DBObject) |
![]() |
DisableUndoRecording | Controls the undo recording of this object in
OdDbDatabase. (Inherited from DBObject) |
![]() |
Dispose | (Inherited from DisposableWrapper) |
![]() |
Dispose(Boolean) | (Inherited from DBObject) |
![]() |
DowngradeOpen | Downgrades this object from ForWrite
to ForRead. (Inherited from DBObject) |
![]() |
DowngradeToNotify | Downgrades this object from ForNotify
and ForWrite to having just one open mode
- ForNotify. Currently not
implemented. (Inherited from DBObject) |
![]() |
DwgIn | Reads the .dwg file format data of this object from the
specified file. (Inherited from DBObject) |
![]() |
DwgInFields | (Inherited from DBObject) |
![]() |
DwgOut | Writes the .dwg file format data of this object to the
specified filer. (Inherited from DBObject) |
![]() |
DwgOutFields | (Inherited from DBObject) |
![]() |
DxfIn | Reads the .dxf file format data of this object from the
specified file. (Inherited from DBObject) |
![]() |
DxfInFields | (Inherited from DBObject) |
![]() |
DxfOut | Writes the .dxf file format data of this object to the
specified filer. (Inherited from DBObject) |
![]() |
DxfOutFields | (Inherited from DBObject) |
![]() |
Equals | (Inherited from DisposableWrapper) |
![]() |
Erase | Marks this object as "erased". (Inherited from DBObject) |
![]() |
Erase(Boolean) | Sets the erased mode of this object. (Inherited from DBObject) |
![]() |
Finalize | (Inherited from DisposableWrapper) |
![]() |
GetAlignment | (Inherited from FormattedTableData) |
![]() |
GetBackgroundColor | (Inherited from FormattedTableData) |
![]() |
GetBlockAttributeValue | Returns the attribute value of the block cell using the
specified object ID key as a string. (Inherited from LinkedTableData) |
![]() |
GetBlockTableRecordId | Returns the ID of the block table record of the zero content of
a cell. (Inherited from LinkedTableData) |
![]() |
GetCellState | Returns the state of the cell. (Inherited from LinkedTableData) |
![]() |
GetCellStyle | Returns the cell style of the specified cell. |
![]() |
GetColumnName | Returns the column name as a string value. (Inherited from LinkedTableData) |
![]() |
GetColumnWidth | Returns the width of the specified column. |
![]() |
GetContentColor | (Inherited from FormattedTableData) |
![]() |
GetContentTypes | Returns the content type of the first content of a cell. (Inherited from LinkedTableData) |
![]() |
GetCustomData | Returns the custom data value of a cell, column or row. Use a
valid row index and pass the column index '-1' to get the row data.
Use a valid column index and pass the row index '-1' to get the
column data. (Inherited from LinkedTableData) |
![]() |
GetDataFormat | Returns the data format of the specified content of a
cell. (Inherited from LinkedTableData) |
![]() |
GetDataLink | Returns a collection of data link object IDs. (Inherited from LinkedTableData) |
![]() |
GetDataLink(CellRange) | Returns the data link object ID for the specified cell
range. (Inherited from LinkedTableData) |
![]() |
GetDataLink(Int32, Int32) | Returns the data link object ID for the specified cell. (Inherited from LinkedTableData) |
![]() |
GetEnumerator | Returns the enumerator for this object. (Inherited from LinkedTableData) |
![]() |
GetEnumerator(TableEnumeratorOption) | Returns the enumerator for this object. (Inherited from LinkedTableData) |
![]() |
GetEventExtender | (Inherited from DBObject) |
![]() |
GetField | Returns the object ID of a "TEXT" field object from the field
dictionary. (Inherited from DBObject) |
![]() |
GetField(String) | Returns the object ID of the specified field object (that
matches the property name) from the field dictionary. (Inherited from DBObject) |
![]() |
GetFieldId | Returns the field ID of a cell. (Inherited from LinkedTableData) |
![]() |
GetGridColor | (Inherited from FormattedTableData) |
![]() |
GetGridLinetype | (Inherited from FormattedTableData) |
![]() |
GetGridLineWeight | (Inherited from FormattedTableData) |
![]() |
GetGridVisibility | (Inherited from FormattedTableData) |
![]() |
GetHashCode | (Inherited from DisposableWrapper) |
![]() |
GetLifetimeService | Retrieves the current lifetime service object that controls the
lifetime policy for this instance. (Inherited from MarshalByRefObject) |
![]() |
GetMargin | (Inherited from FormattedTableData) |
![]() |
GetMergeRange | (Inherited from FormattedTableData) |
![]() |
GetObjectSaveVersion(DwgFiler) | Returns the drawing and maintenance release version into which
this object must be stored. (Inherited from DBObject) |
![]() |
GetObjectSaveVersion(DxfFiler) | Returns the drawing and maintenance release version into which
this object must be stored. (Inherited from DBObject) |
![]() |
GetOverride(Int32, Int32, Int32) | (Inherited from FormattedTableData) |
![]() |
GetOverride(Int32, Int32, GridLineType) | (Inherited from FormattedTableData) |
![]() |
GetPersistentReactorIds | Returns the object IDs of this object's persistent
reactors. (Inherited from DBObject) |
![]() |
GetReactors | Obsolete. Returns this object's transient reactors. (Inherited from DBObject) |
![]() |
GetRotation | (Inherited from FormattedTableData) |
![]() |
GetRowHeight | Returns the height of the specified row. |
![]() |
GetRXClass | (Inherited from RXObject) |
![]() |
GetScale | (Inherited from FormattedTableData) |
![]() |
GetTextHeight | (Inherited from FormattedTableData) |
![]() |
GetTextStyle | (Inherited from FormattedTableData) |
![]() |
GetToolTip | Returns the tooltip of the cell. (Inherited from LinkedTableData) |
![]() |
GetTransientReactors | Returns this object's transient reactors. (Inherited from DBObject) |
![]() |
GetType | Gets the Type of the current
instance. (Inherited from Object) |
![]() |
GetValue(Int32, Int32) | Returns the value of the zero content of a cell. (Inherited from LinkedTableData) |
![]() |
GetValue(Int32, Int32, Int32, FormatOption) | Returns the value of the specified content of a cell. (Inherited from LinkedTableData) |
![]() |
GetXDataForApplication | Returns a linked list of ResBufs containing a copy of the XData
of this object. (Inherited from DBObject) |
![]() |
HandOverTo | Replaces this database-resident (DBRO) object with the
specified non-database-resident (NDBRO) object, while retaining
this object's objectId, handle, owner, and reactor list. (Inherited from DBObject) |
![]() |
HasContext | Checks whether the specified context exists in the
collection. (Inherited from DBObject) |
![]() |
HasPersistentReactor | Checks whether the passed identifier is an identifier of a
reactor attached to this object. (Inherited from DBObject) |
![]() |
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime
policy for this instance. (Inherited from MarshalByRefObject) |
![]() |
InsertColumn | Inserts the specified number of columns into this linked table
object at the specified column index. (Inherited from LinkedTableData) |
![]() |
InsertRow | Inserts the specified number of rows into this linked table
object at the specified row index. (Inherited from LinkedTableData) |
![]() |
IsContentEditable | Checks whether cell content can be edited. (Inherited from LinkedTableData) |
![]() |
IsFormatEditable | (Inherited from FormattedTableData) |
![]() |
IsLinked | Checks whether a cell is linked to a data source. (Inherited from LinkedTableData) |
![]() |
IsMerged | (Inherited from FormattedTableData) |
![]() |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object) |
![]() |
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject
object. (Inherited from MarshalByRefObject) |
![]() |
Merge | (Inherited from FormattedTableData) |
![]() |
QueryX | (Inherited from RXObject) |
![]() |
RegenSupportFlags | (Inherited from Drawable) |
![]() |
ReleaseExtensionDictionary | Releases and erases this object's extension dictionary if it
exists and is empty. (Inherited from DBObject) |
![]() |
RemoveAllOverrides | (Inherited from FormattedTableData) |
![]() |
RemoveContext | Removes a context from the collection. An active context can't
be removed. (Inherited from DBObject) |
![]() |
RemoveField | Removes the text field and returns its field ID. (Inherited from DBObject) |
![]() |
RemoveField(ObjectId) | Removes the specified field. (Inherited from DBObject) |
![]() |
RemoveField(String) | Removes the specified field by its name and returns its
ID. (Inherited from DBObject) |
![]() |
RemovePersistentReactor | Removes the specified persistent reactor from this object's
reactor list. (Inherited from DBObject) |
![]() |
ResetScaleDependentProperties | Resets object properties that depend on scale to the default
values. (Inherited from DBObject) |
![]() |
SetAlignment | (Inherited from FormattedTableData) |
![]() |
SetAttributes | Sets the vectorization attributes of this object, and returns
its attribute flags. (Inherited from Drawable) |
![]() |
SetBackgroundColor | (Inherited from FormattedTableData) |
![]() |
SetBlockAttributeValue | Sets the attribute value of the block cell using the specified
object ID key. (Inherited from LinkedTableData) |
![]() |
SetBlockTableRecordId | Sets the ID of the block table record of the zero content of a
cell. (Inherited from LinkedTableData) |
![]() |
SetCellState | Sets the cell state. (Inherited from LinkedTableData) |
![]() |
SetCellStyle | Sets the cell style of the specified cell. |
![]() |
SetColumnName | Sets the column name. (Inherited from LinkedTableData) |
![]() |
SetColumnWidth | Sets the width of the specified column. |
![]() |
SetContentColor | (Inherited from FormattedTableData) |
![]() |
SetCustomData | Sets the custom data value of a cell, column or row. Use a
valid row index and pass the column index '-1' to set the row data.
Use a valid column index and pass the row index '-1' to set the
column data. (Inherited from LinkedTableData) |
![]() |
SetDataFormat | Sets the data format of the zero content of a cell. (Inherited from LinkedTableData) |
![]() |
SetDataLink(CellRange, ObjectId, Boolean) | Sets the data link object ID for the specified cell
range. (Inherited from LinkedTableData) |
![]() |
SetDataLink(Int32, Int32, ObjectId, Boolean) | Sets the data link object ID for the specified cell. (Inherited from LinkedTableData) |
![]() |
SetDataType | Sets the data type of the first content of a cell. (Inherited from LinkedTableData) |
![]() |
SetField(Field) | Sets the specified field for the "TEXT" property. (Inherited from DBObject) |
![]() |
SetField(String, Field) | Sets the specified field for the specified property. (Inherited from DBObject) |
![]() |
SetFieldId | Sets a field ID to the zero content of a cell. (Inherited from LinkedTableData) |
![]() |
SetFromStyle | Sets the annotative property of an object according to its
corresponding style, such as styles of text objects. (Inherited from DBObject) |
![]() |
SetGridColor | (Inherited from FormattedTableData) |
![]() |
SetGridLinetype | (Inherited from FormattedTableData) |
![]() |
SetGridLineWeight | (Inherited from FormattedTableData) |
![]() |
SetGridVisibility | (Inherited from FormattedTableData) |
![]() |
SetMargin | (Inherited from FormattedTableData) |
![]() |
SetObjectIdsInFlux | Called on a newly created cloned object to indicate that its
object ID is not valid. (Inherited from DBObject) |
![]() |
SetOverride(Int32, Int32, Int32, CellProperties) | (Inherited from FormattedTableData) |
![]() |
SetOverride(Int32, Int32, GridLineType, GridProperties) | (Inherited from FormattedTableData) |
![]() |
SetPaperOrientation | Sets the paper orientation property of a specified
object. (Inherited from DBObject) |
![]() |
SetRotation | (Inherited from FormattedTableData) |
![]() |
SetRowHeight | Sets the height of the specified row. |
![]() |
SetScale | (Inherited from FormattedTableData) |
![]() |
SetSize | Sets the size for this linked table object. (Inherited from LinkedTableData) |
![]() |
SetTextHeight | (Inherited from FormattedTableData) |
![]() |
SetTextStyle | (Inherited from FormattedTableData) |
![]() |
SetToolTip | Sets the tooltip of the cell. (Inherited from LinkedTableData) |
![]() |
SetValue(Int32, Int32, Object) | Sets a value to the zero content of a cell. (Inherited from LinkedTableData) |
![]() |
SetValue(Int32, Int32, Int32, Object, ParseOption) | Sets a value to the specified content of a cell. (Inherited from LinkedTableData) |
![]() |
SubRegenSupportFlags | (Inherited from Drawable) |
![]() |
SubSetAttributes | (Inherited from DBObject) |
![]() |
SubViewportDraw | (Inherited from DBObject) |
![]() |
SubViewportDrawLogicalFlags | (Inherited from DBObject) |
![]() |
SubWorldDraw | (Inherited from DBObject) |
![]() |
SupportsCollection | Checks whether a particular context type is supported by this
object. This method shows whether an object supports a collection
type but does not show whether this object participates in any
contexts of that type. (Inherited from DBObject) |
![]() |
SwapIdWith | Swaps the objectIDs, handles, extended data (XData), and
extension dictionary between this object and another object. (Inherited from DBObject) |
![]() |
SwapReferences | This method performs object ID reference translations similar
to those done at the end of deep cloning. References between
objects in the workset have their object identifiers translated to
the swapped object identifiers of the referenced objects. In
contrast to cloning, this translation must occur in both
directions. Accordingly, it is possible to pass two different ID
maps in two different calls to this method. Currently not
implemented. (Inherited from DBObject) |
![]() |
ToString | Returns a string that represents the current object. (Inherited from Object) |
![]() |
UnitType | Returns the unit type of the first content for the cell. (Inherited from LinkedTableData) |
![]() |
Unmerge | (Inherited from FormattedTableData) |
![]() |
UpdateDataLink(UpdateDirection, UpdateOption) | Updates the data link in the table. (Inherited from LinkedTableData) |
![]() |
UpdateDataLink(Int32, Int32, UpdateDirection, UpdateOption) | Updates the data link of a cell. (Inherited from LinkedTableData) |
![]() |
UpgradeFromNotify | Upgrades the object from at least ForNotify mode to both ForNotify and ForWrite
modes. You should place a call to DowngradeToNotify() with no Open() or Close() methods
in between. For internal use. Currently not implemented. (Inherited from DBObject) |
![]() |
UpgradeOpen | (Inherited from DBObject) |
![]() |
ViewportDraw | Creates a viewport-dependent geometric representation of this
object. (Inherited from Drawable) |
![]() |
ViewportDrawLogicalFlags | Retrieves the setAttributes flags for the current
viewportDraw. (Inherited from Drawable) |
![]() |
WblockClone | Performs a shallow clone of this object. (Inherited from DBObject) |
![]() |
WorldDraw | Creates a viewport-independent geometric representation of this
object. (Inherited from Drawable) |
![]() |
X | (Inherited from RXObject) |
![]() |
XDataTransformBy | Applies the 3D transformation matrix to the XData of this
object. (Inherited from DBObject) |
Name | Description | |
---|---|---|
![]() |
Cancelled | (Inherited from DBObject) |
![]() |
Copied | Notification event called whenever the notifying object has had
its clone() member function called. (Inherited from DBObject) |
![]() |
Erased | Notification event called whenever an object has been erased or
unerased. (Inherited from DBObject) |
![]() |
Goodbye | Notification event called just before an object is deleted from
memory. (Inherited from DBObject) |
![]() |
Modified | Notification event called whenever an object is opened
ForWrite, a function has been called that
could modify the content of this object, and this object is now
being closed. (Inherited from DBObject) |
![]() |
ModifiedXData | Notification event called whenever the XData has been written
to the notifying object. (Inherited from DBObject) |
![]() |
ModifyUndone | Notification event called whenever the notifying object is
currently performing an undo operation that is undoing
modifications. (Inherited from DBObject) |
![]() |
ObjectClosed | Notification event called immediately before an object is
closed. (Inherited from DBObject) |
![]() |
OpenedForModify | Notification event called whenever an object is opened for
modifying ForWrite. (Inherited from DBObject) |
![]() |
Reappended | Notification event called whenever a redo process processes the
reappending of the notifying object to the database. (Inherited from DBObject) |
![]() |
SubObjectModified | (Inherited from DBObject) |
![]() |
Unappended | Notification event called whenever the undo process processes
the appending of the notifying object to the database. (Inherited from DBObject) |
© Bricsys NV. All rights reserved. |